Reply
Highlighted
SanDisk User
Posts: 64
Registered: ‎11-08-2008
Accepted Solution

Trying to clear up AA questions: E200 & Fuze different files?

Just to check before I do something like toss a sansa against the wall...

I am trying to get my Album Art to show up in my 260. I drag & drop my files into it. Don't use anything to sync with. I use the same set-up for my Fuze & have no trouble. But with the 260, I get nada showing unless I rename the folder.jpg files to Album Art.jpg.

Is this right??? The two players recognize different file names? Do I really need two different versions of my album art to see it on both players? Please tell me I'm missing something very basic, here. If not, anyone know of an EASY way to batch rename the files?

E260 V1/Fuze V1 - both running Rockbox.

Thanks.

Highlighted
SanDisk User
Posts: 38
Registered: ‎06-25-2009

Re: Trying to clear up AA questions: E200 & Fuze different files?

Rockbox recognizes "cover.jpg" for album art.
Highlighted
SanDisk User
Posts: 64
Registered: ‎11-08-2008

Re: Trying to clear up AA questions: E200 & Fuze different files?

It will also see folder.jpg, which is what all of my AA is named. Would there be a reason that it will see "folder" on te fuze & not on the E260?
Highlighted
SanDisk Guru
Posts: 16,321
Registered: ‎04-17-2008

Re: Trying to clear up AA questions: E200 & Fuze different files?


rsdown wrote:
It will also see folder.jpg, which is what all of my AA is named. Would there be a reason that it will see "folder" on te fuze & not on the E260?

 

Don't know about RB, but maybe yes in the OF, if the e260 is a v1 model. They use a different processor chip than the v2 series and the Fuze.
Highlighted
SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: Trying to clear up AA questions: E200 & Fuze different files?

You'll notice that the e200 series players will handle album art differently.  There are differences between the e200 v1 and v2 machines, with the later e200v2 machines having yet another quirk, still present because of firmware changes.

 

The Fuze supports embedded album art from the ID3 tag data, as well as the separate jpg folder.  The issue of missing album art is most easily remedied using MP3Tag, and the "export album art as jpg" function.  MP3Tag can pull the embedded art, and transfer a jpg file to the requisite album folder for you- the same thing that you can do manually if desired.

 

I'm spoiled, as I take advantage of the MTP protocol and pipeline, letting the album folders populate automatically upon transfer.

 

So, you may ask, why would I do such a thing?  When it comes to the music, I let the Sansa and WiMP find a happy relationship, so I don't have to tinker too much when it comes to my personal machines.  I love to delve into problems, so I have fun intentionally messing things up, finding solutions for my friends here.

 

WiMP11 likes to go "off the reservation" now and again, one of the things that adds spice to life.

 

If you are curious about the e200 v2, the bug remains regarding album art transfers.  If you manually transfer album art.jpg files to the Sansa, the device adds a reference to each album art image in the Photos folder, so you can browse your album art as well as personal photos.  This can get  confusing, no doubt!  The secret in this case is to set the jpg attributes to hidden during the transfer, and the Sansa will leave the files alone.

 

Bob  Smiley Very Happy

Highlighted
SanDisk User
Posts: 64
Registered: ‎11-08-2008

Re: Trying to clear up AA questions: E200 & Fuze different files?

I got this cleared up, I think. Not sure what the problem was but I re-installed RB from scratch, and now all the art shows up. Flaky. Thanks for the help, anyway.
Highlighted
SanDisk Guru
Posts: 16,321
Registered: ‎04-17-2008

Re: Trying to clear up AA questions: E200 & Fuze different files?


rsdown wrote:
I got this cleared up, I think. Not sure what the problem was but I re-installed RB from scratch, and now all the art shows up. Flaky. Thanks for the help, anyway.

Were you running an older version of Rockbox? If you were, that may be it; you updated the RB firmware to a current version. That may be why your album art is working now. I believe .jpg support for album art wasn't introduced until Version 3.1 (about a year ago). Prior to that album art had to be in .bmp format to be recognized or used in Rockbox. I think that's one of the reasons you see so many RB themes without album art. 1.) Art takes up valuable space that can be used for data display, and 2.) Many people didn't want to convert all their album art to .bmp for Rockbox when it was already in .jpg format for the Sansa firmware. Of course, now things have changed and AA is now 'cool' again.