Reply
Highlighted
Newbie
Posts: 1
Registered: ‎03-25-2008

Failer code 10 with e250

Hi

I can not see my e250 (SDMX4-2048-E70) when I connect to computer (Windows XP sytem showing code 10 failer during controller instalation)

and....

in e250 settings I don't have USB mode folder ????

Thanks

 

Highlighted
SanDisk Guru
Posts: 1,667
Registered: ‎01-12-2008

Re: Failer code 10 with e250

No USB mode option in the menu?  You must have one of the v2 models that Sandisk rushed to market at the end of 2007, with the buggy firmware.  I guess they were trying to get in on the holiday sales bonanza.  Can't say I blame them too much, but...

 

First off, you'll want to update your firmware.  Download the Sansa Updater app from the sandisk.com website.  Here's a direct link to the sansa updater, which said link might or might not work since you have to jump through a few rings to get to it. 

 

It's possible you might need to put the player in MSC mode in order for the updater to do its thing.  You can force MSC mode by:

 

1. Engage Hold button (orange should be showing)

2. Press and hold the Left (REWIND) button and keep it held down

3. Connect to USB port on computer (not to USB hub or USB extension cable)

 

Once the computer indicates you have plugged something into a USB port, you can let go of the REWIND button.  Congratulations, you are now in MSC mode, a.k.a. the Mode of Sansa Champions.  The Sansa Updater should come up with an icon in the system tray.  It's sort of an S looking thingamabob.  Right Click and select Update Now, and then follow the onscreen instructions.

 

If you're running a proxy, you might have to go the manual firmware update route since the auto updater won't be able to connect to the Internet through a proxy.  I suppose a firewall could also be blocking access in some cases.  The manual firmware update steps are covered in one of the stickies at the top of the e200 forum main page.

 

After the firmware update is finished, you will then have the USB menu options Auto, MTP, and MSC.  To get the computer to accept the player in MTP (a.k.a. the Mode of Trouble and Perplexity) mode can be tricky at times, though MSC mode usually works without a hitch.  The first thing to do is update Windows Media Player to the latest and greatest version (currently version 11).  Try removing the player icon from Device Manager.  Sometimes that will cause the computer to correctly reinstall the MTP drivers.  If that doesn't work or if you're already running version 11, roll back to version 10 and remove the Microsoft User Mode Driver Framework Something or Other and the Windows Media Format 11 Runtime Something or Other from Add/Remove Programs in Control Panel.  If it's still not working, and while still running WMP version 10, download fixup.zip, extract the archive, and execute fixup.cmd from a command prompt window.  It's a script.  What exactly it does, I don't know, exactly.  My understanding is it basically removes the stuff that's keeping Windows from correctly installing the MTP drivers.  Windows *should* now correctly get the MTP drivers up and going.  Once that's done, you can update back to WMP 11 and it should still work.

Highlighted
Newbie
Posts: 1
Registered: ‎11-13-2008

Re: Failer code 10 with e250

I am having a similar issue... We just bought a new computer with Windows Vista. I installed all the software for my Sansa sandisk e250, and it shows up on the computer; everythings fine. BUT, when I open the program and it prompts me to plug in my player, it does NOT recognize it... I have plugged it in many times and never did it recognize that. My computer recognizes it however, and goes to "autorun", asking me what action to take... but I cannot view and manipulate my music on the player this way. HELP!!
Highlighted
SanDisk Guru
Posts: 16,321
Registered: ‎04-17-2008

Re: Failer code 10 with e250

1.) You should start a new thread, rather than latching on to an 8 month old one.

 

2.) You haven't mentioned anything about a Code 10 error msg. that would make yours a 'similar' issue.

 

3.) But as long as you're here . . .

 

 

I'm sorry you had to settle for a new computer with Vista on it. My condolences . .  . just kidding, but we hear from a lot of people with Vista compatibility problems. I only run XP so I can't help you much there, but . . .

 

When you said, "when I open the program and it prompts me to plug in my player" exactly what program are you opening? If it's Windows Media Player, your player must be in MTP mode to 'sync' up with it. You can change this in SETTINGS > USB mode.

 

When you say, "My computer recognizes it however, and goes to "autorun", asking me what action to take... but I cannot view and manipulate my music on the player this way." This tells me your player is probably in MSC mode (the other USB option). There is nothing wrong here. That is what is supposed to happen (autorun). MSC allows your computer to see your player as another storage device/drive. It's very simple to drag & drop files (songs) to it in this mode. It is the preferred mode for most of the 'old-timers' here. Smiley Wink

 

If you cannot see or 'manipulate' your music, it means that it was put on in MTP mode. Content put on in one USB mode is not visible in the other. So as in the previous paragraph, you probably need to switch the USB mode to MTP and you'll be OK. Smiley Happy