Posts: 2
Registered: ‎02-20-2008

Sansa View Freezes on startup screen Every time


I Have an 8gb Sansa View. I Have had this particular device since November 2008. Incidentally this is the 4th View I have had. I had to return the first one to the store where I bought it once and then I rma'ed it twice. Each time it had a different problem. Each new one I got fixed one problem but then developed a new problem.

The one I have now since November had been working fine, but then it started taking a long time to start up, so I decided to reformat the device and reinstall the firmware. I did this by first putting the device into msc mode, by turning the device on, putting the power switch on hold and then holding down the left button on the wheel while plugging into the computer. I then reformatted the device, by going into My Computer, right clicking on the Sansa drive and then selecting to reformat. That all went well and everything on the device was erased. I then unplugged the device after selecting to safely remove it from the computer, and shut the device off by holding the power button up for 20 seconds. I Then set the power switch to hold and began the process of reinstalling the most recent firmware. With the power switch on hold I Held down the home/menu button while plugging into the computer. The device connected and the 16mb Format sansa folder came up. This is when I Downloaded the latest firmware from the Sandisk website, Firmware 1.03.02a. I unzipped the files onto my desktop and then I took all 5 of the unzipped files and copied them into the Sansa View's 16mb format folder. Next I clicked to safely remove the device from the computer and unplugged it. On the device everything seemed to be installing right as I looked at the view's screen. The View shut off and then I went to turn it on and that is where the problem began. Now everytime I go to turn it on the device gets stuck on the Sandisk Sansa black screen and doesn't go past that screen. I tried numerous times at resetting the device by holding the power switch up for 20 seconds but that did no good. I tried reinstalling the firmware again the same way but that didn't work either. This is the only way I can attempt to install the firmware now at this point because I can't get past the sansa black screen and the device won't connect to my computer any other way now except for the recovery mode way. I even tried The older firmwares. I tried every way but the device just will not turn on now. It gets to the black sansa screen and says Sandisk, Sansa and the blue ring and other lights stay illuminated the whole time also, but the player never comes on. I kept it that way for an hour today hoping it would come on but it never did.

   If anyone has any suggestions on anything else I could try to get this working again I would greatly appreciate it. The Warranty expired in December, so I don't think I can RMA it again. So I Guess I Might be stuck with this incredible piece of junk.

 Thanks to anyone who can provide any help.