Reply
Highlighted
Newbie
Posts: 4
Registered: ‎08-04-2009

usb cable charges but does not connect

I know this problem has been mentioned before, and I have searched countless web pages through Google about this problem and have not found a solution.

 

I have a Fuze 4gb that used to be able to connect to my PC, but now it just charges and does not connect. I have not done anything to alter my PC or my fuze. This just happened out of the blue. 

 

And don't tell me to upgrade the firmware (how could I upgrade the firmware if my Fuze doesn't connect?!). 

 

Anyone have any suggestions?

Highlighted
SanDisk Guru
Posts: 16,318
Registered: ‎04-17-2008

Re: usb cable charges but does not connect

Have you tried un-installing (not dis-enabling, thst's something different) it in Device Manager, re-booting the computer, and plugging it in again?
Highlighted
Newbie
Posts: 4
Registered: ‎08-04-2009

Re: usb cable charges but does not connect

It's not possible to un-install it in device manager, because it needs to be plugged into the computer and recognized in order to remove the driver.
Highlighted
SanDisk Guru
Posts: 3,233
Registered: ‎09-13-2008

Re: usb cable charges but does not connect

Some people have mentioned that after service pack 3 for windows XP was installed on their PC, their player would not connect to the pc in MTP mode until after they reinstalled Windows Media Player 11. Rather than reinstalling Windows Media Player, I  switched my players to MSC mode. Since I don't use protected files, there is no need for me to use MTP. I decided a while ago that MSC is better than MTP for those without protected music, but was too lazy to make the switch.
Highlighted
Newbie
Posts: 4
Registered: ‎08-04-2009

Re: usb cable charges but does not connect

I'm using Vista, and have not altered my system in any way.

 

My USB charger just suddenly decided to not connect with my PC, even though it does charge the Fuze.

Highlighted
SanDisk Guru
Posts: 3,233
Registered: ‎09-13-2008

Re: usb cable charges but does not connect

Perhaps an update for Vista could have done something similar to what service pack 3 did for Windows XP? Have you tried connecting using MSC mode? Have you tried using  a different USB port? Have you tried disconnecting all other USB periperals before connecting the player? Have you tried using a different pc?
Highlighted
SanDisk User
Posts: 46
Registered: ‎12-25-2008

Re: usb cable charges but does not connect

looking at this thread, my problem might be similar to your problem, so i'll watch this thread for updates, too.
Highlighted
SanDisk Guru
Posts: 1,018
Registered: ‎02-05-2009

Re: usb cable charges but does not connect

Have you tried using another usb cable?  One of the pins may have become loose or bent, preventing a connection.
Highlighted
Newbie
Posts: 4
Registered: ‎08-04-2009

Re: usb cable charges but does not connect

First I want to say thanks to everyone who replied. I didn't expect anyone to reply because I've had bad experiences with these troubleshooting forums lol

 

Anyway, I've tried connecting my Fuze to my laptop which is Windows XP but it still doesn't connect. I've tried using different modes on the Fuze, and it still doesnt work. I've used all of my USB ports, still doesn't work.

 

I'm thinking it could be the cable, because my Fuze and computers work flawlessly and nothing has changed. But it still charges, so that's what's weird.

Highlighted
SanDisk Guru
Posts: 1,018
Registered: ‎02-05-2009

Re: usb cable charges but does not connect

It's really not so strange.  The pins for data transfer and the pins for charging are two different lengths.  If I remember correctly, the pins for charging are longer than the ones for data.