Reply
Highlighted
Newbie
Posts: 4
Registered: ‎06-20-2009
Accepted Solution

SansaFuze 2GB problem

Just recently, my computer has not been able to pick up my Sansa Fuze 2GB. Before it would read it just fine with no problems and now it refuses to cooperate. I was pretty sure I had the drivers for it, although thats what it's asking for. Nothing seems to give at this point, can someone possibly give me a solution to this problem? I run on Windows Vista 32
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: SansaFuze 2GB problem

Go into Settings/USB Mode, switch to MSC, and see if it connects. The only driver is the same one that is already runnint all your USB ports. 

 

If not, go into Device Manager--I'm not sure of the path in Vista, but it's via Control Panel and probably System or Hardware--and see if there is a yellow triangle with an exclamation point. Right-click on it, Uninstall (not Disable), reboot and try connecting again. Should work.

 

 

Then try again with USB Mode MTP. MTP  works with Windows Media Player, which has the drivers. You may need to reinstall WMP, from Microsoft's website. 

Newbie
Posts: 4
Registered: ‎06-20-2009

Re: SansaFuze 2GB problem

I tried your solution and it still doesn't work
SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: SansaFuze 2GB problem

Which USB mode were you using?  As described above, there are two communications modes, with MTP running as a virtual mode supported by Windows Media Player.

 

We need a bit more information regarding your preferred mode, and just what steps you've taked to remedy the situation.

 

Bob  Smiley Wink

SanDisk Senior User
Posts: 185
Registered: ‎08-01-2008

Re: SansaFuze 2GB problem

It also helps to know your OS (Operating System). While most people think "Micro$oft Windoze" when they think PC, PC can also refer to Linux, Solaris, etc.

 

It shouldn't matter what OS you use, it should just work, the drivers should automatically be there. But it might help to troubleshoot if we knew the OS.

--Pikidalto
Newbie
Posts: 4
Registered: ‎06-20-2009

Re: SansaFuze 2GB problem

I did mention my OS, which is Windows Vista 32.

 

The Sansa used to always work on my computer until just recently. I had it on Auto i believe the whole time and my computer decided to give it problems. Ive tried installing drivers, uninstalling and reinstalling the Sansa Fuze 2GB drivers. 

Newbie
Posts: 4
Registered: ‎06-20-2009

Re: SansaFuze 2GB problem

I figured out the problem. I created an Administrator account and then I was able to install the drivers required to read the Sansa. Even though I had to restore to Factory settings, it now works just as it did again. Thanks to those who tried to help!