Reply
Newbie
Posts: 1
Registered: ‎01-13-2012

Sansa Fuze SanDisk will not charge

[ Edited ]

I cannot charge my Sansa buy fake watches Fuze Sandisk - neither at the mains nor with a USB. It turns on, shows 'connected', then 'writing', then goes back to showing 'connected' and the 4-coloured 'flower' icon in the centre revolves, but the battery does not show the charging symbol and remains white and uncharged.  I have held the 'on' button on the side for various lengths of time and all it does is turns it off.  When I turn it on again the whole scenario starts again.  It's not the cable because I have just bought another and it does the same thing with the new cable.

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa Fuze SanDisk will not charge

Try to force an MSC connection. Leave the unit off. Slide the power switch down to click into Hold. Connect the USB end to your computer. Open Windows Explorer (Computer or My Computer). Hold down the << side of the wheel and connect to the Fuze.

 

Don't use a USB hub and if you're using a laptop, connect to the port nearest to the back of the computer, which provides the most power.

 

If that doesn't work, the port is probably broken. 

 

The unit has a one-year warranty. If it's older than that, it's time to start looking for a replacement.

Newbie
Posts: 2
Registered: ‎12-23-2007

Re: Sansa Fuze SanDisk will not charge

I just bought a Fuze+ 4 GB.... updated it to the latest FW... loaded gobs of music on it.... used it and was pretty pleased.  Except... it turns out it was a total waste of time

I was going away for the weekend and noticed the battery was down more than halfway.  Plugged it in to every single USB port on 3 differnt computers and a powered hub and NONE of them would give me the charging indication.  So I read everything I could about this issue and went out to Best Buy and picked up a 2 Amp Dynex wall charger and plugged it in.  Got the battery charging indication but after 3 hours the charge on the battery had not changed.

I have a nice (but old and small) e250.  Plugged it in and the Dynex showed a red LED indicating a current drain.  (The LED remained green when the Fuze+ was plugged in.)  In 3 hours the e250 charged but no change with the Fuze+ even though the battery indicator was moving back and forth.  So I unpugged the Fuze+ and left it on until it shut itself off due to low battery.

 

It won't turn on now.   When I try there is a large image of a battery with a small red bar on the screen.   I plugged it into the Dynex and the Fuze+ turns on as it should.  The battery indicator on the Fuze+ suggests it's charging but I know it isn't.  The LED on the Dynex flickers red once and then goes green.  The Dynex wall adaptor is keeping it on but the Fuze+ isn't pulling enough current to charge itself.

 

Is anybody out there to offer advice?   I posted this situation 2 days ago on another thread and got no response.  I'm posting here becaue this thread isn't tagged as solved.   Do I need to start a new thread? 

 

I'm leaving town in a few hours and taking the e250.  If there isn't any response.  I'm going to send the Fuze+ back to Amazon and add my negative review when I get back to town next week.

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa Fuze SanDisk will not charge

This is the Fuze board, not the Fuze +

 

Sounds like you need a warranty repair or replacement. Call 1-866-SANDISK.

Newbie
Posts: 2
Registered: ‎02-16-2013

Re: Sansa Fuze SanDisk will not charge

hi. i have an old sansa fuze that has now started doing this issue.

 

i have tried on 4 different pcs (some with windows vista e some with windows 7) and they all show that the device is not recognizeble.

 

i have also tried 2 other cables, 1 from my older sansa e280 and 1 cable from my friend that also has a fuze 2gb.

 

the unit of course is not under warranty anymore... and i am currenly living in brazil, so there is no way to send it in for now.

 

i was wondering if someone could tell me if this is usually the case of a faulty battery?

 

i was thinking in buying a battery from ebay and replace it myself... to start with...

 

but in case this is not usually a battery issue, i would probably just get rid of the  player and buy something new.

 

can anyone here please give me some light?

 

i thank you very much for your time and reading this! have a nice day Smiley Happy

Newbie
Posts: 2
Registered: ‎02-16-2013

Re: Sansa Fuze SanDisk will not charge

sorry, me again.

 

i forgot to write on my post above that i have also tried using a wall charger that works with the other unit and also have tried the reset in the menu as well as the reset with the power button.

 

nothing worked so far.

 

thanks!

Newbie
Posts: 1
Registered: ‎07-10-2014

Re: Sansa Fuze SanDisk will not charge

my sandisk will not charge in any usb port and i changed the mode to MSC....

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa Fuze SanDisk will not charge

It could be a broken cable. You can find a generic replacement on Amazon for under $5 if you are willing to spend that much to make the test.

Newbie
Posts: 20
Registered: ‎05-13-2014

Re: Sansa Fuze SanDisk will not charge

Exitony, does the computer see the player? If not, I'd bet on the cable, like Black Rectangle said.

Newbie
Posts: 11
Registered: ‎06-21-2011

Re: Sansa Fuze SanDisk will not charge

I have been using my Sansa Fuze+ for years.  I always used the same USB cable and charged it with my laptop, never had any problems until now.  I went on vacation and left the player at home for a long time. When I got back the battery was zero and it wouldn't power up.  I used the same USB cable to plug it in my laptop it powered up and indicated "connected" but it was not charging or doing anything.  I couldn't use it to listen to music or for anything else.  I could use it if I had it plugged in directly to an outlet but it still wouldn't charge.  As soon as I unplugged it it's dead once again.  

 

I wonder if the battery is complete dead because I let it drain to zero and now it will no longer hold a charge.  Anyone else has the same experience?