Reply
Newbie
Posts: 2
Registered: ‎02-15-2012

I really think my Fuze 8GB is dead

I have spent a couple days trying every trick I can find on this forum and short of a supernatural miracle I think my player is dead. I have a white screen that will not go away under any circumstance.  I have done the following: (in no particular order)

 

Formatted the player 

Manually tried to do a firmware update 

Started working in MTD format and somehow ended up in MSC

Held the power button for 15 seconds, 30 seconds, several minutes

Held the power and home button for different durations (see above)

Held the power and select button for different durations

Thought about throwing it up against the wall....*grin*

 

Is there anything else I can do aside from tossing it in the trash?

 

Thanks

-DB

SanDisk Guru
Posts: 1,265
Registered: ‎04-24-2009

Re: I really think my Fuze 8GB is dead

If it still mounts in MSC mode (e.g. its just the screen thats not working), it could just be that the screen connector came lose. Not sure I recommend this since its really hard to do, but you can open the player and reinsert the screen connector into its socket. Its tricky to get the connector into place and then put the player together without ripping or breaking something though.
Newbie
Posts: 2
Registered: ‎02-15-2012

Re: I really think my Fuze 8GB is dead

Thanks for the suggestion.  At this point I'll try just about anything.  

SanDisk User
Posts: 23
Registered: ‎11-28-2009

Re: I really think my Fuze 8GB is dead


@jarsrose wrote:

Thanks for the suggestion.  At this point I'll try just about anything.  


When you said, 'Thought about throwing it up against the wall....*grin*' LOL.... You weren't too far off from a solution some of us have had to use. I tap mine on a book or any soft surface avaliable, another poster uses his thigh. I opened my fuze up and the video cable was properly seated. I even resat the video cable and that didn't help. I hope you fair better.