Reply
SanDisk User
Posts: 84
Registered: ‎02-11-2009
Accepted Solution

Firmware update software screwed XP's USB hub and USB drive drivers.

Installed firmware update software, updated fuze and everything worked fine. Then, I turned my computer off for the night.
 
Turned computer on in the morning, and now USB hub and USB drives are no longer powered or recognized. In device manager, they are listed as "Unknown Device," Device Status: No drivers installed.
 
Updated to XP SP3. Tried uninstalling all motherboard USB controllers, hubs and drivers, then reinstalling. No luck.
 
Currently looking for a fix.
 
This is pathetic. 
SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

I can't see where or how updating a portable player would have that sort of effect on a computer's operating system.

 

Did you update the firmware manually or download & use the Updater?

 

When un-installing USB ports/drivers and re-installing, you have to re-boot the computer in-between for it to work properly (un-install | re-boot | re-install).

SanDisk User
Posts: 84
Registered: ‎02-11-2009

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

Used the updater.  Boy was I stupid to do that, should have known it would be poorly designed and cause problems.  I looked for a manual method but didn't see one right away, should have looked harder. 

 

It's the updater software installed on XP, that's what caused the problem. Nothing else was changed other than installing the updater.

 

I did reboot after uninstalling MOBO USB controllers. No luck.

SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: Firmware update software screwed XP's USB hub and USB drive drivers.


@maxplanck wrote:

Used the updater.  Boy was I stupid to do that, should have known it would be poorly designed and cause problems.  I looked for a manual method but didn't see one right away, should have looked harder

 

It's the updater software installed on XP, that's what caused the problem. Nothing else was changed other than installing the updater.

 

I did reboot after uninstalling MOBO USB controllers. No luck.


 

Well, I have to agree (at least partially) with you.

 

The manual instructions are in the 'sticky' (shaded) Firmware Update post at the top of the Fuze board where it will always be easy to find and accessable. It actually takes less time to manually update the firmware than it does to install the Updater and wait for it to do it for you.

 

Out of the thousands of people who post here on the forum, I have never heard of the Updater causing the USB problems you are citing, so I find it hard to believe that it is truly (and by itself) to blame.

 

However, the damamge is done now, regardless of the cause. Maybe you should try reverting Windows back to a previous 'system restore point'. That why they are there and available; to turn back the clock if you encounter a system problem you can't fix. This should restore the system to like it was before this happened.

Newbie
Posts: 1
Registered: ‎03-01-2009

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

You are looking in the wrong direction. Try to remember what you did other than installing the firmware updater, that's what screwed your USB drivers.

Highlighted
SanDisk User
Posts: 71
Registered: ‎07-12-2008

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

A one in a million shot and it has to be this cat...
SanDisk Fanatic
Posts: 221
Registered: ‎02-26-2009

Re: Firmware update software screwed XP's USB hub and USB drive drivers.


@maxplanck wrote:
Installed firmware update software, updated fuze and everything worked fine. Then, I turned my computer off for the night.
 
Turned computer on in the morning, and now USB hub and USB drives are no longer powered or recognized. In device manager, they are listed as "Unknown Device," Device Status: No drivers installed.
 
Updated to XP SP3. Tried uninstalling all motherboard USB controllers, hubs and drivers, then reinstalling. No luck.
 
Currently looking for a fix.
 
This is pathetic. 

 

Now let me see if I got this all straight. You said:

 

""Installed firmware update software, updated fuze and everything worked fine.""

 

You did not say if you unplugged the Fuze player and that it completed the upgrade and worked or not. Nor did you say if you plugged the Fuze back in and it connected and/or if you transfered any other files to it. So, I have no idea as to exactly what "worked fine" at that point... your computer, the Fuze, or what?

 

 Then you said:

 

""I turned my computer off for the night. ""

 

OK, but you did not say if you left the Fuze or any other USB devices plugged in and/or if it or any other USB devices had been properly disconnected before you turned the computer off.

 

 Then you said:

 

""Turned computer on in the morning, and now USB hub and USB drives are no longer powered or recognized. In device manager, they are listed as "Unknown Device," Device Status: No drivers installed.""

 

Things start to get really vague here. It almost sounds like you have an external USB hub that you are plugging things into, but I can not be sure from the wording. Not sure why anyone would try to upgrade the firmware of a device plugged in thru an externa USB hub to start with, but regardless of if there is or is not an external hub involved...

 

If all the USB stuff in Device Manager was showing up wrong when you started the computer the next day, then the most logical next step would have been to unplug _all_ the USB devices, restart Windows, and double check to see if there were any problems in Device Manager that might indicate a problem with the motherboard itself. If there were any problems at that stage, then if you suspected the Sansa Updater you should have uninstalled it at that point and restarted the computer to see if things straightened out. If not, then possibly have tried a System Restore to the day before you had installed the Updater.

 

If there were no problems at any of those stages, then plug in one USB device at a time and see if each one worked properly or if one of them showed a problem in Device Manager. It's very possible that one or another USB device became partially unplugged somehow when you turned of the computer and/or before you turned it back on again.

 

Instead of checking all of the above, you said you then:

 

"" Updated to XP SP3.""

 

Say what? You installed something that Windows auto update _should_ have already installed albout half a year ago? Not to mention that XP SP3  was well know to create all kinds of problems, especially with drivers on some older computers. I'm not quite following the logic to installing something with the potential of creating additional problems in order to correct a problem that may not have even existed, or could have been corrected first. After (already very likely royally screwing things up) then you said:

 

""Tried uninstalling all motherboard USB controllers, hubs and drivers, then reinstalling.""

 

Here again, all USB devices should have been unplugged and the computer restarted first to see if Device Manager showed any problems. If, at this point there were problems then you could have had Windows remove that item or uninstall the driver for it, and then restarted the computer to let Windows find and re-install the driver(s) if needed. There's only a small initial motherboard driver that normally has to be installed when Windows is installed the very first time. The rest of the USB port drivers are contained in Windows and it installs them by itself when it detects that the mother board has USB ports. So, I have no idea what you were un-installing and re-installing for that part of things.

 

After all of this _then_ you come into this forum and start ranting about everything being crap. Personally, I don't see how anyone can, or could, help you.

 

 

 

SanDisk Guru
Posts: 3,676
Registered: ‎12-04-2008

Re: Firmware update software screwed XP's USB hub and USB drive drivers.


@miltst wrote:

@maxplanck wrote:
Installed firmware update software, updated fuze and everything worked fine. Then, I turned my computer off for the night.
 
Turned computer on in the morning, and now USB hub and USB drives are no longer powered or recognized. In device manager, they are listed as "Unknown Device," Device Status: No drivers installed.
 
Updated to XP SP3. Tried uninstalling all motherboard USB controllers, hubs and drivers, then reinstalling. No luck.
 
Currently looking for a fix.
 
This is pathetic. 

 

Now let me see if I got this all straight. You said:

 

<--Snip-->

 


The best way to help this guy is not to. He does not want help he just wants to come on here rant and rave and sound like a complere hss aat (Flip the a and h) and then go away. 


Conversion Box
Did you notice this forum has a search function? Its not impossible to figure that someone else asked your question before you did, and we have answered it(probably multiple times). Check it out! Or Check out the Knowledge Base

Moderator
Posts: 497
Registered: ‎01-19-2009

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

You guys are going to "feed the bears" again...  Play nice.

 

I'm curious to see what's up with max's USB.

 

µsansa

SanDisk Senior User
Posts: 139
Registered: ‎10-13-2008

Re: Firmware update software screwed XP's USB hub and USB drive drivers.

Once again, capt vague strikes again! Use restore points, etc. READ the firmware update sticky thread, you know, the RED one at the top?

 

Ranting is one thing, but ranting about a faulty product when you have a faulty computer? Wow....



Ni! A terrifying word.