Posts: 10
Registered: ‎11-24-2015

Re: Computer not recognizing Sansa Fuze - SOLVED!

[ Edited ]

Out of nowhere, my Sansa fuze was not being fully recognized by my computer. I tried a number of the suggestions on this topic thread and found a solution of my own. I haven't read every post but I'll tell you what worked for me.


Plug the Sansa Fuze into a USB port


R-CLICK My Computer


choose properties and then the Device Manager


Under PORTABLE DEVICES I could see my Sana Fuze with a little yellow triangle in it


R-CLICK on the triangle and choose uninstall driver


Disconnect the Sansa Fuze then reconnect it and it's like you connected it for the very first time. The computer searches for the proper driver and VOILA my Sansa Fuze was recognized again as if nothing ever happened.


I hope this helps some of you. OBVIOUSLY, somehow, the USB driver for the Sansa Fuze became corrupted. This worked for me. I hope it helps you as well


Good Fortune to you!!


*NOTE:  I have the Windows 7 64 bit operating system





SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Computer not recognizing Sansa Fuze - SOLVED!

You'll find that exciting solution on page 2 of this thread, from years ago.


It is hardly unique to SanDisk.


If you have connection troubles with any device connecting to Windows--camera, scanner, printer, phone, galactic death ray--it's always good to try going into Device Manager, uninstalling the driver and reconnecting the device.  It finds a nice shiny new driver either in Windows or online. If that doesn't work, then the problem is elsewhere: with the cord, the USB port or the device.


The good thing about SanDisk players is they don't have special proprietary drivers that you'd have to get from SanDisk. Instead, they use drivers that have been built into Windows for at least a decade--the standard USB driver (MSC) or the MTP driver that has been in Windows Media Player since WMP 10 was introduced in 2004.