Reply
Highlighted
Newbie
Posts: 6
Registered: ‎01-22-2011

A really big problem

Hello, I have 2 big problems with my Sansa Fuze (4GB).

 

First problem: This problem happened very lately. My clock on the Sansa shows wrong time. Example: I have set my time at 16th January 2011, 16.58. Next day, I turn it on, it shows me same time (On 17th January, it shows me 16th January, and the same time, when I changed it). Could be this problem with firmware?

 

Second problem: 6 months ago, my screen went messy. It showed me blurry screen, some time even like static screen.

 

How to fix them? If it's with firmware, I can update it once more again. I have the latest update (0.2). Or it's a bug with hardware, I still have guarantee, but I'll better ask professionals.

 

Regards,
Paul

Owning Sandisk products:
Cruzer U3 (1GB)
2x M2 memory cards (both 1GB)
SD memory card (2GB)
Fuze (4GB)
Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: A really big problem

Try updating the firmware one more time. 

 

Follow the manual instructions in this link:

http://forums.sandisk.com/t5/Fuze/Sansa-Fuze-Firmware-Update-01-02-31-amp-02-03-33/td-p/139175

 

Download the All Regions link, not the updater.

 

Unfortunately, it may not be a firmware problem. A separate little long-life  battery runs the clock (and saves settings while the Fuze is turned off). If that battery is dead, it would have to be replaced in the hardware and no one does that because labor time makes it cheaper to buy a new Fuze.

 

If you got the Fuze less than a year ago, it's still under warranty, and you should immediately call 1-866-SANDISK to arrange for a replacement. Otherwise...

Highlighted
SanDisk Guru
Posts: 16,324
Registered: ‎04-17-2008

Re: A really big problem


@IkTech09 wrote:

Hello, I have 2 big problems with my Sansa Fuze (4GB).

 

First problem: This problem happened very lately. My clock on the Sansa shows wrong time. Example: I have set my time at 16th January 2011, 16.58. Next day, I turn it on, it shows me same time (On 17th January, it shows me 16th January, and the same time, when I changed it). Could be this problem with firmware?

 

Second problem: 6 months ago, my screen went messy. It showed me blurry screen, some time even like static screen.

 

How to fix them? If it's with firmware, I can update it once more again. I have the latest update (0.2). Or it's a bug with hardware, I still have guarantee, but I'll better ask professionals.


Sounds more like hardware-related problems to me (but then what do I know?). There's a capacitor/battery inside that holds personal settings and the internal clock, same as on your home computer. If it's not updating, or keeping the correct time it sounds like it has failed.

 

Same with the blurry, or static screen. Sounds like a hardware problem. Go ahead and try a firmware update; you could even try formatting the player but these 2 procedures are all you, as a consumer can do to help reslove an issue. If one of them works, great. But don't be surprised or disappointed if they don't.

 

Is the player still under warranty? SanDisk is very supportive and good about exchanging defective units, but sometimes things fail after the warranty period is up, in which case you just have to buy a new one.

Highlighted
Newbie
Posts: 6
Registered: ‎01-22-2011

Re: A really big problem

[ Edited ]

Thanks for reply Smiley Happy

 

That static effect turned me 5 times: 4 times in deep summer, 1 time 2 weeks ago.

 

I try to update, let's see what it does Smiley Happy

 

Also, I've got 2 years warranity (did I?). I have bought it in November 2009, so warranity should be running Smiley Happy

Owning Sandisk products:
Cruzer U3 (1GB)
2x M2 memory cards (both 1GB)
SD memory card (2GB)
Fuze (4GB)
Highlighted
SanDisk Guru
Posts: 16,324
Registered: ‎04-17-2008

Re: A really big problem


@IkTech09 wrote:

 

Also, I've got 2 years warranity (did I?). I have bought it in November 2008, so warranity should be running Smiley Happy


US = 1 year

EU = 2 years (or so I've heard)

Highlighted
Newbie
Posts: 6
Registered: ‎01-22-2011

Re: A really big problem

[ Edited ]

I live in Estonia, so I still have warranity time Smiley Happy

 

EDIT: Hell no, just when I was trying to update, it went static Smiley Frustrated It's okay in music player, but when I enter system settings, it goes static.

 

I got the firmware version: V02.03.31P

 

EDIT2:  Firmware renew didn't help. As I set clock to 20.16 (08.16pm), after turning it in 2 mins on, it showed 20.15 at all (08.15pm). So far I didn't see static.

Owning Sandisk products:
Cruzer U3 (1GB)
2x M2 memory cards (both 1GB)
SD memory card (2GB)
Fuze (4GB)
Highlighted
SanDisk Guru
Posts: 1,460
Registered: ‎12-27-2008

Re: A really big problem

Two years from Nov. 2008 is Nov. 2010. If you're correct about when you bought it and the length of the warranty, the warranty has expired. Sorry.

Highlighted
Newbie
Posts: 6
Registered: ‎01-22-2011

Re: A really big problem

Oops, an typo. I remember I bought it in my 13th birthday (November 2009 actually). Sorry, it was an typo.

Owning Sandisk products:
Cruzer U3 (1GB)
2x M2 memory cards (both 1GB)
SD memory card (2GB)
Fuze (4GB)