Reply
Highlighted
rbk
Newbie
Posts: 1
Registered: ‎03-29-2008

sansa clip does not power on

I first tried to connect the clip to my pc but it did not show up in the "my computer" window. The clip screen used to show as "connected".

After several attempts,  the clip stopped connecting (screen does not show "connected") and remained in the play mode.

Now the clip does not power up when usb cable is plugged in nor does it power up with the button.

 

Any solution to fix the above problem will be appreciated????

Highlighted
SanDisk Senior User
Posts: 138
Registered: ‎02-12-2008

Re: sansa clip does not power on

Do you have windows media player 10 or newer installed?  Have you tried connecting it on another computer?
Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: sansa clip does not power on

Try connecting with the player in hold, and pressing the center button down while connecting the USB cable between the player and your computer.  That sometimes seems to work.
Highlighted
Newbie
Posts: 1
Registered: ‎04-03-2008

Re: sansa clip does not power on

I also have this same problem. I have 2 clips 1 works fine ! will not turn on or connect to computer.Anybody else have this problem.I suspect I will have to call sansa.
Highlighted
SanDisk Fanatic
Posts: 202
Registered: ‎01-01-2008

Re: sansa clip does not power on

Try holding the power switch slider in the UP position for >15 seconds - this resets the Clip

Idiot Savant
Highlighted
SanDisk User
Posts: 55
Registered: ‎07-08-2009

Re: sansa clip does not power on

I was having the same problem and your reset trick worked great thanks!
Highlighted
Newbie
Posts: 7
Registered: ‎09-06-2008

Re: sansa clip does not power on

yippee, that worked.  I plugged it in to the ubs, held up for 15 seconds and that worked.   I hope this doesn't become an ongoing problem.    I have another older clip and have never had that problem.