Reply
Highlighted
Newbie
Posts: 3
Registered: ‎01-07-2014

Sansa clip+ isn't working

Hello my sansa clip+ isn't working. I plugged in my headphones and it suddenly kinda froze, would shift to my music and volume screen, so I powered it down by holding down the power button for about 25 sec. It worked again for about ten minutes until it repeated the problem. I went home and did a soft shut down and plugged it into a charger. Worked again then died again. Plugged it into the computer and looked like it would work, but now is still at the flower looking loading button. Please help.

Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa clip+ isn't working

Have you added any new files recently?

 

Try putting the USB cord into the computer, holding down the << button and plugging the cord in as you still hold <<. See if that connects.

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Sansa clip+ isn't working

[ Edited ]

If you can do it, you might try reformatting the player under its System settings or under Windows--can sometimes fix odd issues.  Note:  this will erase user content on the player, and so save it to your computer first, if possible.

Highlighted
Newbie
Posts: 3
Registered: ‎01-07-2014

Re: Sansa clip+ isn't working

Tried it and no response. I have added a few music files recently

Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa clip+ isn't working

It could be that one of those new files is making it unhappy. If you could get a computer connection I'd suggest deleting whatever you added most recently and trying again, but it seems like you can't.

 

If you have another microUSB cord from a camera or phone or something, try that in case the cord has gone bad.

 

Otherwise, hate to say it, but your best bet is probably to charge it up and go to Settings/System Settings/Format and wipe off everything.

Highlighted
Newbie
Posts: 3
Registered: ‎01-07-2014

Re: Sansa clip+ isn't working

Ok. I will try it but I think its strange how when I plug in headphones to the jack it starts to freeze...

Highlighted
SanDisk Guru
Posts: 16,324
Registered: ‎04-17-2008

Re: Sansa clip+ isn't working


@aurban2 wrote:

Ok. I will try it but I think its strange how when I plug in headphones to the jack it starts to freeze...


 

Could be a short on the headphone wire/plug. Have you tried a different set of phones?