Reply
Highlighted
Newbie
Posts: 1
Registered: ‎07-11-2009

Sansa 4g clip with serious problems HELP

[ Edited ]
Ok I have had my clip for just under a year with no issues at all. I havent used it in a while and I went to connect it to my computer and it will not stay connected. I will plug it in and it will say connecting for bout 2 seconds go to reading for a second then writting for a second than it will disconnect. It will repeat this like 15 or 20 times before it stops. When it stops it will be recognized by the computer as an unknown device. I cannot update the firmware because the updater does not recognize the device is plugged in. Please help
Message Edited by Tjh9100 on 07-11-2009 03:27 PM
Highlighted
SanDisk Fanatic
Posts: 233
Registered: ‎07-13-2009

Re: Sansa 4g clip with serious problems HELP

You can still update the firmware manually:

 

Update the firmware manually by downloading from the Sansa Forum
1. Go to the Sansa Clip firmware update board on SanDisk's Sansa Community.
2. On your Sansa Clip, verify the hardware revision. 
2.a. From the Main Menu, go to Settings > System Info
2.b. Select Version.  
- If the Version is V01.xx.xxx, you have hardware revision 1.0
- If the Version is V02.xx.xxx, you have hardware revision 2.0. 
3. Instructions on updating are provided in the thread.

 

Hope this helps. Smiley Wink 

Highlighted
SanDisk User
Posts: 65
Registered: ‎06-20-2008

Re: Sansa 4g clip with serious problems HELP

Check the cable, or try with another one. The shorter, the better.