Reply
Highlighted
Newbie
Posts: 2
Registered: ‎05-19-2011

Sandisk 8gb clip+ broke?

Hi, i have a sandisk 8gb clip+ mp3 player and it randomly stopped working a few weeks ago. It originally just failed and wouldn't switch on at all, so i did a google and found the hold power for 30 secs to reset and that seemed to fix it. However i now have a new problem where it switches on and starts to 'refresh media' it gets 1 second in and seems to reboot itself and goes back to sansa flashing up... Then it just proceeds to repeat this process until the battery dies. I can plug it in my pc and add and remove files, it charges up but then whenever i remove it it just keeps repeating the process. Does anyone have any idea what is wrong with it? Is there anyway to wipe the whole mp3 player clean (including its software to restore it back to factory settings?)

Please if anyone has had similar problems did they manage to fix it?

 

Highlighted
Newbie
Posts: 2
Registered: ‎05-19-2011

Re: Sandisk 8gb clip+ broke?

[ Edited ]

 have the software version of 1.02.15 - Should i remove this and reinstall older updates? or is there any newer versions?

 

Edit: Wahey! I reinstalled the firmware manually and it updated again and worked! If anyone else has similar problems i'd suggest this. Hopefully it will stay working Smiley Happy

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Sandisk 8gb clip+ broke?

Genius thinks alike--I was just going to suggest that. Smiley Wink Seemingly the 2 biggest tricks in the SanDisk Clip arsenal: reformatting the player under its settings, and reapplying manually the latest firmware. Good show, and congratulations! Smiley Happy