Reply
Highlighted
Newbie
Posts: 1
Registered: ‎11-01-2016

SanDisk Sansa Clip+ doesn't charge, doesn't turns on or doesn't do a hard reset

Hello everyone!!

 

I have a SanDisk Sansa Clip+ that doesn't charge, nor turns on or can't do a hard reset.

 

I've been using my device to play it with my car using an aux entrance and with an external MicroSD Kingston 32 GB chip. I have charged my device without any problems using a Motorola Adapter Model 5115 with an input of 100-240V (50/60 Hz 0.2A) and an output of 5.0V - 550mA.

 

Yesterday I turn on my device, but got stuck on the logo for like 1 minute, after that it reset itself and again got stuck on the logo, then it shut off by itself. Thought for a moment was a battery drain. When I came home, I plugged it to my Motorola Charge Adapter, usually my device turns on by itself when charging, but this time it didn't turn on. I tried many options from the web: hard reset, pressing power for more than 15, 30, 45 and 60 seconds and nothing; pressing power and for a split second press the  home or middle button and nothing; I connected my device via usb cable to my laptop, pressed the middle button and nothing; I left my device charging the entire night and nothing; guess I'm running out of options... what else can I do to fix my Sansa Player?

SanDisk Guru
Posts: 3,233
Registered: ‎09-13-2008

Re: SanDisk Sansa Clip+ doesn't charge, doesn't turns on or doesn't do a hard reset

[ Edited ]

So you are saying that the player won't connect to your pc, even while holding the player's middle button as you connect the pc to it? Have you tried first removing the card in the player(while the player is off), then trying to connect it to the pc? At first I thought the player's main memory is corrupted and needs to be reformatted, or the memory on the card in the player is corrupted, and the card needs to be reformatted. Formatting these removes all the songs on them. . How old is the player? It might be that the internal memory has become defective or worn out. 

 

I assume you also tried to turn on the player while it was connected to the wall charger and being charged. If it did play then, then you would know the problem is a damaged or worn out battery. The problem though imo is probably a flash memory problem or a problem with the firmware in the player or perhaps hardware in the player that is worn out. Unfortunately if you can't get the player to connect to your pc then you can't try reloading the firmware.