Posts: 2
Registered: ‎03-23-2016
Accepted Solution

Problems connecting to my SanDisk sansa clip+ from a computer.

I am having new problems connecting to my sansa clip+. It worked perfectly at one time.

When it is connected to the computer I see it as a connected USB device but when I try to open/access it I get the following error:

Unable to access “SanDisk Sansa Clip+”

Unable to open MTP device '[usb:002,014]'

I am unable to mount or format it from the computer.

Standalone I did the 20sec power button reset and formatted the player only to loose the few songs that I had on it. I am still not able to access it from the computer.

I did not have extra memory in it for either of these.

Any suggestions???

Posts: 2
Registered: ‎03-23-2016

Re: Problems connecting to my SanDisk sansa clip+ from a computer.

I got a reply from tech support.

After changing to MSC mode I was able to connect and load music files to the player. This problem was something new as I had been connecting before using my linix (Ubuntu) computer in auto detect mode. Maybe an upgrade of the OS caused the problem. Everything is working ok now.


Posts: 2
Registered: ‎02-01-2017

Problems connecting to my SanDisk sansa clip+ from a computer running Ubuntu MATE 16.04.1 LTS

[ Edited ]

As delivered, the USB Mode setting of the Sansa SanDisk is set to "Auto Detect".  You get to this setting as follows:


     Home > Settings > System Settings > USB Mode


The Auto Detect USB Mode is not compatible with Ubuntu for some reason in that the disk images cannot be mounted.  I have not tried this with other Linux distros to date.  Note that this mode does work successfully on MacOSX.


For Ubuntu (and probably other Linux distros), simply set the USB Mode on the Sansa to either MTP or MSC - both work.