Reply
Highlighted
SanDisk Professor
Posts: 579
Registered: ‎12-02-2008

Re: Pitch bug on Clip+?


@michaelc5047 wrote:

Hmmm... as the originator of this thread, I'm interested to see that there are reports of there being pitch bugs with the v1 Clip.

 

I have 2 v1 Clips -- a 2GB and a 4GB and don't hear problems with them (and hear no differences when running Rockbox on either of them). It was an 8GB v2 Clip that played back audibly too slowly to my ears.


Well then, since the clip+ appears to have ~ 1/3 the error of the V1 it should be fine.  
 How well is clip rockbox running?   

 

Highlighted
SanDisk Guru
Posts: 1,581
Registered: ‎11-26-2008

Re: Pitch bug on Clip+?

I just received my clip+ today and don't notice any pitch issues, by ear.  I do agree that the matter should be investigated by Sandisk and corrected.
"Before I sink into the big sleep...I want to hear the scream of the Butterfly"
Highlighted
Newbie
Posts: 4
Registered: ‎08-31-2009

Re: Pitch bug on Clip+?

[ Edited ]

@donp wrote:

@michaelc5047 wrote:

Hmmm... as the originator of this thread, I'm interested to see that there are reports of there being pitch bugs with the v1 Clip.

 

I have 2 v1 Clips -- a 2GB and a 4GB and don't hear problems with them (and hear no differences when running Rockbox on either of them). It was an 8GB v2 Clip that played back audibly too slowly to my ears.


Well then, since the clip+ appears to have ~ 1/3 the error of the V1 it should be fine.  
 How well is clip rockbox running?   

 


It seems to have random stopping/crashing problems if you do things like change albums/tracks (while playing), pause, shuffle, etc., in other words, pretty much the way I listen to my Clip. ;-) But if you're listening to an album straight through from beginning to end, it works fine. Just not ready (yet).

Message Edited by michaelc5047 on 09-05-2009 02:48 PM
Highlighted
SanDisk User
Posts: 63
Registered: ‎02-02-2009

Re: Pitch bug on Clip+?

Still waiting for an answer.
Highlighted
SanDisk Professor
Posts: 579
Registered: ‎12-02-2008

Re: Pitch bug on Clip+?


@Warrior1986 wrote:
Still waiting for an answer.
 
You expect Sansa has people assigned to "cover" the user forum on a holiday weekend?
 

 

Highlighted
SanDisk Guru
Posts: 1,669
Registered: ‎10-07-2007

Re: Pitch bug on Clip+?

Or any other day of the year?
Highlighted
SanDisk User
Posts: 63
Registered: ‎02-02-2009

Re: Pitch bug on Clip+?

[ Edited ]

@donp wrote:

@Warrior1986 wrote:
Still waiting for an answer.
 
You expect Sansa has people assigned to "cover" the user forum on a holiday weekend?
 

 


 

Well, I was going to say no, but seeing as someone posted just an hour ago, then yes. 

 

microsansa posted in this thread.  http://forums.sandisk.com/sansa/board/message?board.id=clipplus&thread.id=293

Message Edited by Warrior1986 on 09-07-2009 02:26 PM
Highlighted
Newbie
Posts: 12
Registered: ‎09-04-2009

Re: Pitch bug on Clip+?

Thinking my first clip+ might be defective, I picked up a second one to test. Here's the results:

 

1000hz

Dell D630c (laptop)  - plays 1000.02hz

Sansa E200              - plays 1000.39hz

Rio Karma                - plays 1000.48hz

1st Sansa Clip+        - plays 1002.47hz

2nd Sansa Clip+       - plays 1002.47hz

 

That gives both Sansa Clip+'s a pitch error of 0.247%, compared to the next player (Rio Karma) at 0.048%.

----------------------------------------

 

From this I can say that this pitch bug is real, and can and should be fixed via firmware. I don't think it's too much to ask for Sansa to at least equal the sound quality performance of their previous generation player, the Sansa E200.

 

Highlighted
Newbie
Posts: 1
Registered: ‎09-10-2009

Re: Pitch bug on Clip+?

[ Edited ]

Here's my pitch test results.  Thanks schnarky42 for the instructions on how to use bidule/gtune. I used the test tones created by forum member davek over in Sansa's Fuze forum in the huge thread about the Fuze pitch problem (supposedly fixed now).  I bought my Clip at Walmart based on their good price and the review I read over at anythingbutipod.com that said how good the support was for the product and how it was frequently updated.  But now it's been more than 6 months since the last firmware update.  I sold my Clip due to your lack of support and frankly because I'm angry  the Clip+ was put out before fixing the pitch problem on the original Clip (maybe that's smart business, but it pisses me off!).  Come on Sansa, this pitch problem has been around since day one.  CNet says the Clip was released on Oct. 8th, 2007.  That's almost two years from now.  Bring the Clip out of BETA!!! Fix the pitch problem!

 

Sansa Clip 8gb V2 (V02.01.32A firmware, original Clip NOT Clip+)

1000hz
44.1k encoded to 44.1k = 988.78Hz
44.1k encoded to 48k   = 1001.61Hz
48k   encoded to 44.1k = 988.78Hz
48k   encoded to 48k   = 1001.61Hz

Samsung SGH-A737 cell phone

44.1k encoded to 44.1k = 1000.01Hz
44.1k encoded to 48k   = 1000.01Hz   
48k   encoded to 44.1k = 1000.01Hz
48k   encoded to 48k   = 1000.01Hz

Message Edited by oofda on 09-11-2009 12:20 AM
Message Edited by oofda on 09-11-2009 12:22 AM
Highlighted
SanDisk Professor
Posts: 579
Registered: ‎12-02-2008

Re: Pitch bug on Clip+?


@wavydavy wrote:

This wrong speed, wrong pitch playback is unacceptable for a modern digital device.

My cheap digital watch is a hundred times more accurate.

This product is unusable by anyone who plays a musical instrument, and wants to play along with the songs on their Clip+, for fun or to learn new songs. 

 

 



Yes, something they should have been able to avoid.
Yes, a bummer to play alongside something else that is in tune.

In the end, I'd say a matter of priorities. If you want a really small player WITH an expansion slot (not to mention FM), your alternative choices get really scarce really fast.
For me, for now, I got the slot and in tune, not that small with an e200. Without some research I couldn't name another brand of straight music player with a memory slot at all. Just phones and PDA's.