Reply
Newbie
Posts: 2
Registered: ‎06-27-2015

New User - Help Needed Please.

Hi

 

I can't seem to transfer anything but the title of the songs from my notebook to my Clip.

 

So i have an album full of 12 songs, each 0 seconds long.

 

Can anyone help please - I have tried the quick answers and have followed the same, but no luck.

 

Thank you

 

Peter

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: New User - Help Needed Please.

Some initial questions:

 

--  Are the songs in a format recognized by the Clip?

 

--  Are the songs copy protected/protected by digital rights management (DRM)?  Where are the songs from?

 

--  How are you transferring the songs?  Simple copy and paste/drag and drop works well.

 

--  What is the player's USB mode (under System settings) set to?  MTP mode sometimes can cause issues;  MSC mode is tried and true.

Newbie
Posts: 2
Registered: ‎06-27-2015

Re: New User - Help Needed Please.

Hi

 

Thanks for helping, here are the answers.

 

CD's copied onto notebook.

 

I have tried the drop n drag, just the titles are transfered onto the clip and none of the song/music, so I get 12 tracks of 0 seconds each.

 

I have tried the USB in MTP and auto, but not MSC so will try that in a mo.

 

cheers

SanDisk Guru
Posts: 1,265
Registered: ‎04-24-2009

Re: New User - Help Needed Please.

What format are the songs in?

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: New User - Help Needed Please.

And perhaps a silly question, but:  you've ripped the CDs, and into a format the Clip recognizes, right?  As you likely know, players can't play CD songs/files natively--the songs/titles need to be converted into a format that players can play/recognize.

SanDisk Guru
Posts: 3,233
Registered: ‎09-13-2008

Re: New User - Help Needed Please.

[ Edited ]

"CD's copied onto notebook."

 

Open Windows Media Player, which is on your pc. Click on tools, options, and on the rip music tab, choose mp3 for the format, rip cd automatically, eject CD after ripping. on the audio quality slider, I suggest choosing 256 kbps, It will say uses around 115 MB per cd. Choose apply, then choose okay.  If you don't see tools, then look for a small box in the lower right hand cornner of the screen with three dots and a small arrow in it, and click on it.

 

 

 

Next put an audio CD in the CD drive of the computer. after a few minutes the CD will eject, and you mp3 files are ready. They will be in a folder for the disc the Documents/music folder. Use Windows Explorer copy and paste to paste the folder containing the album of mp3 files to your player. Before copying the songs to the player, I suggest you format the player using the player's menu to get rid of the sample files on the player(settings, system settings, format), and set the usb mode of the player to MSC(settings, system settings, usb mode, MSC).

 

MSC mode treats the player like a removable drive. The drawback to MSC mode though is that it doesn't support protected files. MTP mode supports protected files(which would also need to be transferred to the player using Windos Media player or other suitable media player). I suggest avoiding MTP mode on the player, unless you must use protected files.

 

 

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: New User - Help Needed Please.

What you "copied" onto the notebook from the CD may well have been not the files themselves but a list of the locations of the files on the CD--especially if it went really fast, and especially since they are only 0kb. You can't just copy--you have to "rip," getting the actual audio information. 

 

The player also skips through files it can't play--including the .m4a files that iTunes rips by default, because Apple doesn't like to play nicely with the other children. 

 

Don't know if you are in Windows or Mac.  They both tend to hide the extensions that tell you what kind of file you have. If you are in Windows, search help for "Hide extensions" to learn how to un-hide file extensions.  If the extension of your files isn't. mp3, wma, wav, flac or .aa  then they probably won't play on your player. 

 

You need to "rip" the music files onto your computer--copy the audio information, either in the original format (.wav) or much smaller compressed files. FLAC files are smaller and lossless for audio perfectionists; .mp3 at 320 kbps  will probably sound just as good unless you are playing them back in a very quiet place on audiophile headphones.

 

WMP will rip your CDs, as explained by JK98.

 

So will iTunes, if that's what you have.

 

If you are using iTunes on your computer, you can go into Importing Settings (often under Edit/Preferences/Advanced, which is different from the Advanced tab that's always shown--but each version of iTunes likes to move stuff around, so check Help if that doesn't work). Change the format from .m4a or other Apple format to .mp3 and go for high quality, 320.  You only have to do it once. Then when you "import"--that is, rip--you'll get mp3 files that play on everything.  

 

On the Sansa, I suggest Settings/System Settings/USB Mode/MSC and then you can just copy stuff onto the internal memory or a microSD card in the slot.  

 

Just to be annoying, Mac OSX also makes "finder" files that it also calls mp3. They start with period underscore like ._01-Track01.mp3. The Sansa thinks those are mp3s--Apple told it they were by putting the mp3 extension on--but they are 0kb and there is no audio information in them. They're usually in a folder called MACOSX. Make sure you  copy the actual mp3 music files--about 10MB per minute of music--onto the Sansa.  

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: New User - Help Needed Please.

Lots of advice from different people--but, need to hear back from the OP as to the OP's own circumstances.