Reply
Highlighted
JT3
Newbie
Posts: 1
Registered: ‎12-13-2008

Re: My sansa clip won't turn-on

I have this same problem, but I can actually get mine to turn on (I have to smack it actaully), but once it does it says "Refreshing Database" for about a split second, the bar moves up and then it shuts off. My brother had the 2G (I have the 4) a year or two ago and his did this exact same thing within a month of having it, and sure enough, it's been nearly 2 weeks with this thing and it's already having this problem. My only conclusion is that these things are deffective, but I could be wrong and it could be a common error we both made.
Highlighted
Newbie
Posts: 1
Registered: ‎01-13-2009

Re: My sansa clip won't turn-on

I have resolved this entire thing by taking apart my own sansa.  There is a red wire that seems to be defective in all sansa clips.  I used an electrical iron and put it back together.  I had two problems actually.  I was in MTP mode and the wire was not attached.  It would charge when connected but without the positive connection it wouldn't turn on.  So I got it working, not I need to do recovery mode or something to fix it.  I'm currently making a youtube video on how to fix this problem if anyone wants to check it out.  It should work if you want to venture opening it up.  I even let you know where is the best place to open it up with and with what.  So I hope this resolves it for a lot of people.  I know I was pissed for a while.

Cheers!

Davia (drumsexy9 at youtube  should be up around jan 14th or 15th 2009)

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: My sansa clip won't turn-on

Thanks for sharing your efforts!
Highlighted
SanDisk User
Posts: 27
Registered: ‎09-14-2008

Re: My sansa clip won't turn-on

Dang, I'm a dead man.  My wife let me use her Clip (I have a fuze) and when I was coming back from the Gym I tried to turn on the clip and it wouldn't turn on. It has been charging for over 5 hours and still doesn't show a full charge and immediatly after disconecting the clip from a wall charger it goes dead and wont turn on.  My wife is not going to be happy Smiley Sad.
Highlighted
SanDisk User
Posts: 27
Registered: ‎09-14-2008

Re: My sansa clip won't turn-on

I got an RMA, I send in my clip, they will take 7-10 days to 'process' my clip and they will eventually send one back.
Highlighted
Newbie
Posts: 2
Registered: ‎01-23-2009

Re: My sansa clip won't turn-on

hey my red wire is disconnected.  What is the best way to strip the wire (it looks so thin), and what is the best way to attach it back to the connection.  Is epoxy cheap? and where could i get some?  (home depot?)
Highlighted
SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: My sansa clip won't turn-on

Epoxy!

 

I think not.  Resin is non-conductive.  The wire needs to be soldered carefully.  If you don't have the proper tools or experience, see if a friend has some electronics experience.  Then you'll have a proper repair.

 

Bob  Smiley Very Happy

Highlighted
Newbie
Posts: 2
Registered: ‎01-23-2009

Re: My sansa clip won't turn-on

no bud, they do sell conductive epoxy used in place of solder.
Highlighted
Newbie
Posts: 2
Registered: ‎01-28-2009

Re: My sansa clip won't turn-on

i've respectivly read all 4 pages as well as other solutions, my screen still goes shot dead after i unplug it

(hold center for 15 seconds while on hold)

(nothing can be added or deleted)

so on and so forth

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: My sansa clip won't turn-on

Likely, then, that the lead to the battery has become disconnected?  If you have warranty left, contact SanDisk?