Reply
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: My Sansa clip+ won't turn on what so ever

The power/reset button is a wonderful thing.   Smiley Happy

Newbie
Posts: 1
Registered: ‎01-22-2015

Re: My Sansa clip+ won't turn on what so ever

I have a sansa clip+. I have owned it less than a week.

It is recognized by the computer, I can add and remove songs. 

The screen never lights up, even when attached to the computer. I charged it all day yesterday on my desktop, but forgot to turn it off before I went to bed. So, charging it again today. Should I move to an A/C charger? I have one of those.

I have updated the firmware, and everything. Why is it not actually lighting up and powering on?

SanDisk Fanatic
Posts: 258
Registered: ‎05-02-2010

Re: My Sansa clip+ won't turn on what so ever

Have you removed the protective strip from the screen?

SanDisk Guru
Posts: 16,210
Registered: ‎04-17-2008

Re: My Sansa clip+ won't turn on what so ever

It's got to be turning on if it is recognized and seen by your computer. Your computer won't 'see' it if it's not powered on.

 

So, it sounds like JaZZ's suggestion is valid. Make sure you have peeled off the screen protector film. It has an screen-shot image on it making it 'appear' to be on when it isn't. But it covers up the real screen, so you can press buttons till you're blue In the face and that image won't change and you can't see under it.

Newbie
Posts: 3
Registered: ‎02-27-2015

Re: My Sansa clip+ won't turn on what so ever

Just wanted to say thanks for this. My refurb zip stopped turning on, and wouldnt even connect to PC just outside the Amazon 30 day returns. I held the power button 30 secs, and that fixed it. Thanks!!!

Newbie
Posts: 1
Registered: ‎06-26-2015

Re: My Sansa clip+ won't turn on what so ever

It Didnt Work so im trying plan "b" if it dont work ima pull out its chip and use that for a mp3 creation >Smiley Very Happy

Newbie
Posts: 3
Registered: ‎02-27-2015

Re: My Sansa clip+ won't turn on what so ever

 Well this works until it happens again. Id say about once every couple days it becomes totally unresponsive. I have to do the reset again and it works for awhile, etc. etc.

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: My Sansa clip+ won't turn on what so ever

What you might try doing is, reapply the latest firmware--there could be a firmware glitch, which can develop over time.  See the firmware thread at the top of this forum--very easy and safe to do.

Newbie
Posts: 12
Registered: ‎08-06-2010

Re: My Sansa clip+ won't turn on what so ever

[ Edited ]

As the Designated Geek, a friend handed me her Clip+ yesterday (she knows I have one, too), and said "Fix it, please?"

 

It wont' boot. 

 

I've tried several different combinations of holding down the power button, plugging it in to a linux machine, an OS X machine, etc.   I've only ever gotten it to display the 'flower' startup logo (that's what I call it), but it won't go any farther than that.

 

The OS X machine says it's a "4.2MB UNDEF Storage Media".

 

The device has got to be several years old; she doesn't have much hope for it.   Still, I'd be a big o'l hero if I could get it working again...!  

 

[edit]  Any chance reformatting it would do me any good?  The OS X Disk Utility shows it as format-able...

Newbie
Posts: 12
Registered: ‎08-06-2010

Re: My Sansa clip+ won't turn on what so ever

Well, reformatting hasn't changed anything.  Still won't mount as a writable device, and I only ever get a "Sandisk" and 'flower' occasionally--but it never goes any further.   Not sure what else to try. 


wilberfan wrote:

As the Designated Geek, a friend handed me her Clip+ yesterday (she knows I have one, too), and said "Fix it, please?"

 

It wont' boot. 

 

I've tried several different combinations of holding down the power button, plugging it in to a linux machine, an OS X machine, etc.   I've only ever gotten it to display the 'flower' startup logo (that's what I call it), but it won't go any farther than that.

 

The OS X machine says it's a "4.2MB UNDEF Storage Media".

 

The device has got to be several years old; she doesn't have much hope for it.   Still, I'd be a big o'l hero if I could get it working again...!  

 

[edit]  Any chance reformatting it would do me any good?  The OS X Disk Utility shows it as format-able...