Reply
Newbie
Posts: 2
Registered: ‎06-23-2011
Accepted Solution

My Sansa Clip DIED.

So I was in the backseat of the car, listening to the music, when all of a sudden, it just DIED. I thought perhaps the battery had died (although this was unlikely as the power was 80+ percent). When I got home, I plugged it into the computer to charge.

 

...nothing.

 

I tried turning it on, holding the buttons down, attempting to get some sign that it might still work, but nothing has happened.

There wasn't anything I was doing that would have caused it to give outm like this.

 

Please help! I'd like to know why it died and if I can fix it!

SanDisk Guru
Posts: 16,269
Registered: ‎04-17-2008

Re: My Sansa Clip DIED.

This scenario and question is asked several times a week . . .

 

Reset it. If you have a Clip (original) hold the sliding power switch on the side in the uppermost position for 20-30 seconds. Don't guess; count it out (one mississippi, two mississippi, etc.), or use a clock.

 

With the Clip+ press and hold the power button for the same amount of time. It should now start up and run normally.

Newbie
Posts: 2
Registered: ‎06-23-2011

Re: My Sansa Clip DIED.

Thank you!

(I wonder why it happens so often...)

Newbie
Posts: 1
Registered: ‎06-24-2011

Re: My Sansa Clip DIED.

Holding the power switch for an extended time does the job.  Thanks for the help!

Newbie
Posts: 2
Registered: ‎12-13-2010

Re: My Sansa Clip DIED.

Old advice - but still works! Thanks

Newbie
Posts: 1
Registered: ‎05-25-2019

Re: My Sansa Clip DIED.

Thank you.  Worked for me!

Highlighted
Newbie
Posts: 10
Registered: ‎04-28-2016

Re: My Sansa Clip DIED.

Thank you for that information, Tapeworm. Duely noted and kudos to you, kind Sir!

 

I'm hoping that cleared the glitches I've been having after not using my Clip+ for about a year, which I posted about elsewhere.