Reply
Highlighted
Newbie
Posts: 7
Registered: ‎02-23-2009

Issues on Vista with Sansa Clip 4gb player

I recently picked up a Sansa 4gb Clip player from a local Best Buy.  Seemed like a great idea at the time, has turned into a giant headache thus far.  I am using Vista Service pack 1 32-bit.  I've read just about every thread/forum pertaining to issues on this player.  I've switched modes on the player, grabbed the mtp fix for mplayer.  I currently have media player 11.  I've done everything thinkable.  I don't have an XP system to test this on, I read that you can firmware update it on an XP system to get this to work on vista.  Any ways to work around this,  I've contacted Sansa with my issue.  Anyone find any means to fix this problem that excluded whats already mentioned out there?
Highlighted
SanDisk Guru
Posts: 3,676
Registered: ‎12-04-2008

Re: Issues on Vista with Sansa Clip 4gb player


@slugmonay wrote:
I recently picked up a Sansa 4gb Clip player from a local Best Buy.  Seemed like a great idea at the time, has turned into a giant headache thus far.  I am using Vista Service pack 1 32-bit.  I've read just about every thread/forum pertaining to issues on this player.  I've switched modes on the player, grabbed the mtp fix for mplayer.  I currently have media player 11.  I've done everything thinkable.  I don't have an XP system to test this on, I read that you can firmware update it on an XP system to get this to work on vista.  Any ways to work around this,  I've contacted Sansa with my issue.  Anyone find any means to fix this problem that excluded whats already mentioned out there?

What exactly is the problem? You listed a ton of fixes, but you didnt mention the problem.


Conversion Box
Did you notice this forum has a search function? Its not impossible to figure that someone else asked your question before you did, and we have answered it(probably multiple times). Check it out! Or Check out the Knowledge Base

Highlighted
Newbie
Posts: 7
Registered: ‎02-23-2009

Re: Issues on Vista with Sansa Clip 4gb player

I'm sorry.  Vista can't locate correct drivers for the device.
Highlighted
SanDisk Guru
Posts: 3,676
Registered: ‎12-04-2008

Re: Issues on Vista with Sansa Clip 4gb player

AHH HAA. Ok What USB mode are you in? The drivers are not spesific to the fuze. Have you tried a flash drive? It may be such a thing as Vista is having trouble with its USB support, Make sure you have all the upgrades, I know I installed 4 more this morning.

Conversion Box
Did you notice this forum has a search function? Its not impossible to figure that someone else asked your question before you did, and we have answered it(probably multiple times). Check it out! Or Check out the Knowledge Base

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Issues on Vista with Sansa Clip 4gb player

Perhaps easiest, did you try connecting in MSC mode?  On the Clip, Settings/USB; if you don't have that option, force an MSC connection by pressing the center button of the off Clip while you connect the USB cable between your comouter and the Clip (and then update the Clip's firmware (see the sticky thread at the top of the forum) so that you get the USB setting option).
Highlighted
Newbie
Posts: 7
Registered: ‎02-23-2009

Re: Issues on Vista with Sansa Clip 4gb player

Flipped between MSC and MTO yesterday, same issue today.  Neither work.  Vista see's my other usb devices, and even my flash drive fine.
Highlighted
Newbie
Posts: 7
Registered: ‎02-23-2009

Re: Issues on Vista with Sansa Clip 4gb player

The issue is Vista or Windows specific.  I was in the lab today on a linux based system, and it saw the portable mp3 player alright.
Highlighted
SanDisk Guru
Posts: 3,676
Registered: ‎12-04-2008

Re: Issues on Vista with Sansa Clip 4gb player


@slugmonay wrote:
The issue is Vista or Windows specific.  I was in the lab today on a linux based system, and it saw the portable mp3 player alright.

Its Vista. But not all Vista. Make sure your USB Drivers are up to date, and tht vista is up to date.


Conversion Box
Did you notice this forum has a search function? Its not impossible to figure that someone else asked your question before you did, and we have answered it(probably multiple times). Check it out! Or Check out the Knowledge Base

Highlighted
Newbie
Posts: 7
Registered: ‎02-23-2009

Re: Issues on Vista with Sansa Clip 4gb player

That I know of my vista usb drivers are up to date as is my O/S
Highlighted
SanDisk Guru
Posts: 1,235
Registered: ‎10-24-2007

Re: Issues on Vista with Sansa Clip 4gb player

Did you try updating to the latest firmware for your device? Its at the top of the Clip Forum.