Reply
Highlighted
Newbie
Posts: 2
Registered: ‎12-06-2010
Accepted Solution

High pitched sqeal after Clip+ firmware update?

I recently got a Clip+ and it was working out great for me until I updated the firmware, I have also tried installing the previous two versions and reformatting, but every time I try to play a song the player dims, freezes, and the earphones let out a loud and continuous high pitched squeal until I reset it.  I assume this is a firmware problem, not sure what else I could have done to mess it up. 

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: High pitched sqeal after Clip+ firmware update?

Well, at least the good news is, you're under warranty.

 

I'd try:  reset the Clip (hold the on switch down for 20-30 seconds); reformat the Clip, under its settings; and then reapply the latest firmware (see the firmware upgrade sticky thread at the top of the forum).  If that doesn't work, you might want to telephone SanDisk Customer Service for help.  In the U.S.:  1-866-SANDISK (726-3475); and other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us

 

If all else fails, you might want to exchange the player back with the seller, if easy and convenient; otherwise, SanDisk Customer Service can replace it for you.

 

Good luck!  And keep us advised.

Highlighted
Newbie
Posts: 2
Registered: ‎12-06-2010

Re: High pitched sqeal after Clip+ firmware update?

After trying a whole bunch of stuff, I will just assume this certain one was defective and return it.  I hope the next one doesn't die out on me too...