Reply
Highlighted
SanDisk User
Posts: 27
Registered: ‎12-28-2009

Folders confusion - maybe a bug?

I had the Clip+ in Auto USB mode, and was getting a numeric string in front of the name of some of the Artists and/or Album titles.  Based on suggestions from the forums, I moved all of the music off of the Clip+, changed to MSC USB mode, formatted the Clip+ and then copied the music back via Windows Explorer. 

 

All seemed good, but I went to play my Meat Loaf (Bat I, II and III) via the folders on the Clip+, and only Bat I and II showed up, however, on via Windows Explorer, Bat I was displayed. 

 

When I do "Play All" within the Meat Loaf folder, the songs from Bat I are there, but there was no Bat I folder.  I then deleted the Bat II and Bat III albums from the clip, and re-copied them from my computer.  I have the same result.  Windows Explorer sees the Bat I folder, when doing Play All, the songs from Bat I are played/displayed, but the Bat I folder does not show up in the Meat Loaf folder on the Clip+.

 

I installed the firmware update just in case, and still have the same issue.

 

Anyone have any ideas if I am doing something wrong, or if maybe this is an issue with the Clip+?

 

A thought that just came to me... does the Clip+ actually use the folder hierarchy when viewing folders, or does it use MP3 tags?  If so, if the MP3 tag artist were MeatLoaf rather than Meat Loaf, would the Clip+ not show it in the Meat Loaf folder (it does not show a MeatLoaf folder, and I have not checked the tags)?

 

By the way, the songs are stored in WMA format in case that matters.

 

Thanks,

 

Eric

Highlighted
SanDisk User
Posts: 22
Registered: ‎10-03-2009

Re: Folders confusion - maybe a bug?

I have been having similar problems and think that it is definitely a bug. The clip+ is in MSC USB mode and everything on it has been loaded while it has been in that mode.  But when playing under "folder" files or folders sometimes do not show up at all and sometimes files are out of order. But when I look at the files/folders through Windows Explorer or the Mac's finder, everything shows up correctly

 

For example I was listening to an audo book yesterday and noticed a "disconnect" in the story line. So I looked into what was happending and saw that the player had gone from track 6 to track 9 (skipping track 8). I went forward a bit and saw that track 8 was present but that the Clip+ was placing it between tracks 11 and 12!