Reply
Highlighted
SanDisk User
Posts: 82
Registered: ‎02-03-2009
Accepted Solution

Earbud Stopped Working

I have 3 clips and standard OEM earbuds. On one the R bud just quit working.I handle them carefully.Any way to fix or troubleshoot, or just replace?

Highlighted
Newbie
Posts: 5
Registered: ‎01-25-2011

Re: Earbud Stopped Working

I think if the other headphones work on the one with a broken one. We can replace it. I love the OEM buds though.

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Earbud Stopped Working

These buds are so relatively inexpensive, I don't know that people really try to fix them--I haven't seen people post much, if anything, on that.  It could be that the wire/cord has gone bad, not uncommon with earphones, or something in the bud itself.  You could try jiggling the cord a bit to see if that fixes things--if it does, it would seem to be a cord issue and, I guess, you could cut the cord iff where you think the issue is and splice a new cord, such as from some other dead phones, to the cord. 

 

Personally, I'd just get some new earbuds, if you need them--many, many good options around, at good prices, and with improved sound.

Highlighted
SanDisk User
Posts: 82
Registered: ‎02-03-2009

Re: Earbud Stopped Working

I did take it apart at the bud to see if solder joint had broken but it was intact. Moving cord showed nothing. Assume either burned out or a break somewhere in bvetween. May try checking contituity with a meter, but now am just using one of the other two sets since cant use 3 clips at a time anyway. If need be, I will just get a newset.