Reply
Highlighted
SanDisk User
Posts: 35
Registered: ‎09-05-2009

Re: Audio books filed in "Unknown" folder

Come to think of it, maybe I should stay in MSC mode for all books.  The books never expire on the Sansa Clip so maybe those codes you mentioned are not sent, even if the transferring is done in MTP mode.  The codes may be only used when Overdrive downloads them to your computer from the library's website.  That way I could edit the codes on the Clip+ itself using mp3tag.  Or am I still missing something?  Thanks.

Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Audio books filed in "Unknown" folder

[ Edited ]

I like MSC mode for everything. It's transparent and logical. The more you can use it the better.

 

If you take Audiobooks from CDs, rip them with whatever you want and run them through mp3tag with the (Tools/Options/Tags/Mpeg) Write default as ID2.3 ISO-8859-1. You can highlight all the files in the folder and put Artist (author) Album (book) etc. to be whatever you want, all at once. You might check to see if ripping them with iTunes will tag them automatically, which would save you some typing time--but iTunes does ID3v2.2. Sigh.

 

One thing I do with mp3tag is go to Tools/Auto-Numbering Wizard/ and choose the Leading Zeroes option. This makes the tags 01, 02, etc. The reason to do that is that Sansa is stupid: it will play 1, 11, 12, 13...etc....before 2. Using that option also makes everying ID3v2.3 ISO-9959-1 because I set that as the default.

 

I don't use Overdrive, though I've looked up a lot of stuff about it.  Call me old-school, I prefer reading (ebooks included).

 

But if you can get books from Overdrive, put them on your computer, send them to the Sansa via MSC and still have them play without expiring...go for it. The codes I'm talking about are hidden from the user and sent via MTP. You can't touch them (and neither can MC Hammer.)  But if your books are not expiring on the Sansa, great. If they are, you'll need to do MTP for those.

 

I suspect the Unknowns are ID3v2.4, which has been around for some time now despite SanDisk's indifference. Changing them to ID3v2.3 ISO-8859-1 should make them visible.

 

 

Highlighted
Newbie
Posts: 17
Registered: ‎01-09-2013

Re: Audio books filed in "Unknown" folder

OK, I orignated this thread and am back for a second round. I have been using Kid3.app to tag audiobooks downloaded from my library's Overdrive.(I found this suggestion on blog) I check each book after downloading to my Mac and make sure the tracks are tagged as Audiobook, numbered and titled. It has been working flawlessly for a year but yesterday I downloaded 4 mp3 books. After running them all through Kid3 I copied them to my SansaClip+. Two books show up in Audiobooks under their right name. The other two are in Audiobooks/Unknown and mixed alternating tracks. (by the way, the transfer function for Overdrive isn't supported for Macs. You have to copy and paste in Finder.)

 

So I ran those two books through the tag process again. No change. I tried making new folders for the books and moving the tracks to the new folders, no change. One book does show up in Folders. the file extensions are all the same.

 

So what has changed from one week to the next?

 

I have 2 clips so I tried copying one of the books to that device. That book is also in Audiobooks/Unknown, and shows up in Folders on this device but not the first one.

 

And please, if you have a solution phrase it so a kindergarten user can follow. I use this for casusal listening and don't want to spend hours at this task! The only thing I use the clip for is listening to audiobooks because every few months I have to reformat it to clean it of "stuff" or it gets too full of hidden files.

 

Update: Just tried moving one book to the Podcast folder and while it still shows up as Unknown at least it isn't mixed up with the other book.

Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Audio books filed in "Unknown" folder

You need to make sure Genre is Audiobooks--sounds like you are doing that. And make sure they are in the Audiobooks folder. The Podcast folder is treated slightly differently from the Music folder, which keeps it separate, but your problem is still with the tags since you are seeing Unknown. 

 

Some  tag--title?--must be missing or unreadable on the Unknowns. In Kid3, rewrite the title yourself and save it--don't just accept what Overdrive provides. 

 

And this is just a guess but...double-check your Kid3 settings  (or options or whatever it's called) to make sure the tags you are writing are ID3v2.3 ISO-8859-1  (there are various versions of ID3 tags and that's the one Sansa likes).  If they are ID3v2.4 the Sansa may not be able to read them.  Newer books may have switched to ID3v2.4 . 

Highlighted
SanDisk User
Posts: 35
Registered: ‎09-05-2009

Re: Audio books filed in "Unknown" folder

I think I have finally understood what is going on with tags on books placed in the Audiobook folder on the Clip+.  Please let me know if I say anything wrong.  I am also interested in knowing whether or not what I am saying also holds for other Sansa MP3 models.

 

When you place an item in the Audiobooks folder (using Overdrive or Windows Explorer) the Genre tag becomes irrelevant.  I have books in there with the Genre tag history, for example.  No matter in what way you have the Audiobooks folder divided into subfolders and files, the Clip+ pays attention only to the various tags associated to the different tracks.

 

When you go Audiobooks on your Clip+, you first see an alphabetical list of all Album tags for your tracks.  It is important that distinct books that you wisn to play in a particular sequence of tracks have their tracks with the same Album tag.  For example, I once had both 1 Kings and 2 Kings from an audio bible with the same album tag, Word of Promise (Name of the particlar audio bible) and it started to play the first track of 1 Kings followed by the first track of 2 Kings followed by the second track of 1 Kings, etc.  I fixed the problem by changing the Album tags to respectively 1 Kings and 2 Kings.

 

When you select a particular Album, the Clip+ display shows a list of the different Title tags associated with the selected Album tag.  It has been my experience that the Clip+ doesn't do anything but display them and the order it plays the tracks is determined by the Track tag.   However, to start at track 1, (or 01 or 001 or 0001) it should be clear what Title tag is associated with track 1.  When you select a particular title tag and start to listen, the display shows from top to bottom: Track tag in the form 02/17 or 76/104 where 17 and 104 are the respective number of tracks in the albums; Artist tag; Title tag (again).   

 

So my bottom line is: to identify you book on the Clip+ and play it in the correct sequence of tracks, use MP3Tag to give it its own Album tag and make sure the tracks are displayed in order before (if necessary) adding track tags  with the correct number of leading zeroes.

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Audio books filed in "Unknown" folder

That indeed sounds correct.  It's just "the basic":  have your tags with the correct info.

Highlighted
SanDisk User
Posts: 35
Registered: ‎09-05-2009

Re: Audio books filed in "Unknown" folder

I made a mistake in my message above.  I should have give 076/104 as a proper tag.  If you don't have the proper number of leading zeros, 10/104 will play right after 1/104. 

Highlighted
SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Audio books filed in "Unknown" folder

[ Edited ]

Indeed. That's why mp3tag has Leading Zeros under Tools/Auto-Numbering Wizard.

 

And as far as I know, all Sansas work pretty much the same with tags.

Highlighted
SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Audio books filed in "Unknown" folder

And this also is how folder view seems to work across players--the need to use leading zeros in filenames.

Highlighted
Newbie
Posts: 1
Registered: ‎01-12-2016

Re: Audio books filed in "Unknown" folder

The fact that it requires leading zeroes tells us that the code does an ASCII sort (where short strings are "less than" longer ones regardless of initial character), instead of a numerical one.

 

Summary (at least for Clip+).  Set tags thus:

 Genre = "Audiobook"

 Album = book's title

 Artist = author

 Title = chapter*

 Track is ignored

 Discnumber is ignored

 

* If the book was a stack of CD's, I use %discnumber%%track%.