Reply
Newbie
Posts: 1
Registered: ‎09-22-2016

SanDisk Ultra II drive sometimes reports as 3GB link speed.

Hello there,

 

I have 2 Slightly different SanDisk Ultra II 480 GB drives.

 

Model String: SanDisk SDSSDHII480G FW Version: X31200RL

Model String: SanDisk Ultra II 480GB FW Version: 41100RL

 

The 2nd drive in my list above sometimes reports that its connected at 3GB instead of 6GB. A reboot will usually solve this (not always) but I'm curious as to the source of this issue and how to resolve it.

 

I'm using an Asus Z170 Pro motherboard which should support upto 4 SATA 3.0 devices so some basic troubleshooting has lead me here to ask about the actual SSD.

 

Thanks.

 

 

Highlighted
Newbie
Posts: 5
Registered: ‎10-20-2016

Re: SanDisk Ultra II drive sometimes reports as 3GB link speed.

I have exactly the same problem as you. Here in the forum are several other people who also have the same issue. I even contacted SanDisk about this, requesting a firmware update as their SanDisk Extreme SSD seems to have had the same issue in the past till they came up with a firmware update for it.

 

You can see this problem appearing in their firmware release notes:

- Improved compatibility with certain systems where SATA link sometimes negotiated to SATA 2 vs SATA 3.

 

Link:

http://forums.sandisk.com/t5/SanDisk-Extreme-Pro-SSD/Firmware-update-X21200RL-released-for-SanDisk-E...

 

 

I personally have the SanDisk Ultra II and a Samsung 850 Pro. My Samsung SSD doesn't have this problem. However every time i restart my computer my SanDisk Ultra II changes from Sata 3 to Sata 2 mode lowering my write and read performance by half.

 

I already contacted SanDisks support via E-Mail but i don't think they are going to help me as their answers seem automated.

I would really appreciate if someone from their techsupport could dig deeper into this problem and tell us what's going on, otherwise i think we have to return our SSD's to get our cash back.