Reply
Highlighted
Jle
Newbie
Posts: 1
Registered: ‎01-12-2019

Re: Invalid Parent Path in Archive

HELP. Removing the dot on the index worked, forcing it to reindex. Only took about a minute.

 

But...it keeps getting corrupt. 3 times in 2 days. How do I stop it from getting corrupted?

Highlighted
Newbie
Posts: 1
Registered: ‎02-17-2019

Re: Invalid Parent Path in Archive

Didn't work for me!!!

But it obviously repaired some corruption for you?

Highlighted
Newbie
Posts: 2
Registered: ‎12-30-2018

Re: Invalid Parent Path in Archive

I would do the process again, move off all the data, and use some other type of encrypted USB drive. I can't tell you why it keeps doing it. Mine has been fine ever since.

@Blackbill44, yes it reindexed everything perfectly.
Highlighted
Newbie
Posts: 1
Registered: ‎10-30-2019

Re: Invalid Parent Path in Archive

 Try right click on usb flash drive icon, properties and click on Repair Vault. It works for me. Hope this helps.

scandisk_pic.JPG
Highlighted
Newbie
Posts: 3
Registered: ‎12-22-2019

Re: Invalid Parent Path in Archive

Try this, it worked for me, probably, until the next time it doesn't...using version 3...maybe works with version 2?

 

Each time you do a "repair" it basically creates a new index.dat file. I found my index.dat file by following this rabbit hole: clicking the "SanDiskSecureAccess Vault" file with a vault icon -> scrolling to the bottom -> that's where the index.dat lives (rather, repeatedly dies). I've had index.dat, indexdat (without the "dot" as mentioned elsewhere), index.dat (2), index.dat (3), etc etc. 

 

DELETE them all. That's right, delete all of the index.dat files as you'd like to delete Sandisk (or others in bed together) from your life permanently for this annoying tactic to bridge you into the cloud and thereby make it easier for you to lose all data (and a fortune with monthly payments) to nefarious backroom deals regarding "security" and "privacy". It's scary, yes, be brave. At least you might learn a little. 

 

Do a final "repair". It will make an index.dat file. Yaye. This time it seems to be linked and synced...until the next time it isn't of course...or until it's "no longer supported", as if it was in the first place.

 

Tips: Don't ever love a company, it'll never love you back. Love people instead. Dogs are people too. Perhaps buy an alternative brand to SanDisk, and back up to them as well. Now you've got SanDisk, and some other brand, each with your data in case one is targeted. Keep your usb, ssd, etc in an electrostatic bag, then a ziplock, then a fireproof box (or buy a safe deposit box and keep data off-site but rely on, and pay, the bank). BestBuy gave me some free e-bags when they continually screwed the pooch. You can buy some. Don't mess with the other files, they're there "for your security, so that everything will be okay, and the situation is contained". Just click the SanDiskSecureAccessV3_win, enter your password, and hope you aren't dooped again. Mac people, no idea what your problems are, but they're probably similar. 

 

Alternatively, don't use Sandisk if their support isn't up to par. Go and get some fresh air ; ) while we still have some...

 

By, for, of, 

Lab

 

P.S. (5 years after the original post, lol)

Highlighted
Newbie
Posts: 2
Registered: ‎12-28-2019

Re: Invalid Parent Path in Archive

It is dec 2019. I got the same problem on my iXpand mini drive - invalid password when getting into vault on iPhone.
I search on internet n can’t find a solution.
Somehow I plug the drive into pc n same issue when accessing vault but the error is diff - invalid parent path in archive.
Search using this n find a hint to solve. ( thx jb12345 ).
In computer, open folder - iXpand n rename the file index.dat to indexdat ( remove “.” )
Then open the vault again n will ask to repair the index.
After some time ( depends on how many vaults ), it is done.
Can access back the vault using password - no error. But the secured data might not be recovered. It depends how u put the files / photo into the vault before.
If it is copied from iPhone to iXpand then secured , sorry can’t recover the correct index n can’t see the data.
If it is copied using usb from pc to iXpand drive, it is able to access back.
Also i can reproduce the error by exporting WhatsApp chat history n save into iXpand drive . This will ruin the index n cause the error. I guess when moving data into iXpand drive by other app inside iPhone , will cause the error.
Better use the iXpand app to copy photo , music .... for data like WhatsApp chat history , I export to a certain place in iPhone, then copy it using app like FILES or FOLDERS into iXpand drive.
Highlighted
Newbie
Posts: 1
Registered: ‎01-19-2020

Re: Invalid Parent Path in Archive

The only thing that ended up working for me was to delete the index file and then repair (as others have suggested), but then immediately back-up the vault to my hard drive before trying to open the vault. After then restoring from the back-up to the thumb drive everything was OK and I could access the vault and transfer the files to another device.