Posts: 2
Registered: ‎12-11-2015

Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

SanDisk Professor
Posts: 544
Registered: ‎12-10-2014

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011



i think that it would more easy to provide some more information on your issue to help you further. 



Good Luck

#Missing the keyboard? Press F1 for help#
Posts: 2
Registered: ‎12-11-2015

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

I want to replace  my old hdd with sandisk ssd plus 240 on macbook pro 2011. Does it work properly on my mac? OR only work on window laptop?

SanDisk Guru
Posts: 4,548
Registered: ‎07-18-2007

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

the SSD is a 2.5" SATA ssd so yes it will work. That said I am not sure what SATA chipset is in that Mac but if it has the Nvidia MCP79 SATA chipset the SSD will only link up at SATA 1.5GB speed. The Nvidia MCP79 SATA chipset that was used in some Macbooks has a bug and does not negotiate the correct SATA link speed for most SATA 6Gb SSDs. 


You can find the SATA shipset under Mac HDD > Applications > Utilities > SATA/SATA Express

Posts: 2
Registered: ‎12-15-2015

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

I have this SSD installed in my late 2011 13" Macbook Pro and it works just fine.


I've MAC OS X El Capitan installed.


I also enabled TRIM support. You can read more about this here:

Posts: 2
Registered: ‎12-15-2015

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

I checked SATA/SATA Express under system information on my macbook pro late 2011 and here are the SATA chipset details:


Intel 6 Series Chipset:


  Vendor: Intel

  Product: 6 Series Chipset

  Link Speed: 6 Gigabit

  Negotiated Link Speed: 6 Gigabit

  Physical Interconnect: SATA

  Description: AHCI Version 1.30 Supported

Posts: 2
Registered: ‎04-18-2016

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

[ Edited ]

Hi, I think that the newly released OS X El Capitan 10.11.4 update now prevents this SSD to be used. They no longer work on my mid-2012 13" 2.5 GHz Apple MacBook Pro (MBP)  I had a boot failure right after the upgrade... I am a computer engineer and I have spent around 3 days trying to fix it, and working like more than 8+ hours each day... Completely screwed up my weekend. But I guess it's not SanDisk's fault... Seems like Apple added some security into the 10.11.4 update which prevents unsigned/unapproved devices/drivers to work. I had 2 of these drives (one was completely unopened), nothing works, things I've tried include:


- OS X Recovery (CMD+R at boot) to re-partition and/or format the disk with the Disk Utility

- Single user mode (CMD+S or CMD+OPTION+S)

- Verbose mode to see what was going on at the booting phase (CMD+V)

- Safe mode (hold shift while powering on)

- Trying to install El Capitan 10.11.4 via an offline installer (offical installer provided by Apple)

- Turning off System Integrity Protection ("csrutil disable" and reboot). Details here:

- Turning on the developer mode for Kernel Extensions (kext) (which I noticed right now has became obsolete with El Capitan anyway)

- Trying OS X Internet Recovery to download latest over the internet...

- Resetting NVRAM and SMC...

- Checking FW levels on the SSD and health etc. through a Windows PC (all were okay)

- Probably a lot more stuff that I can't remember...

- Trying to run First Aid on the partition I created (which failed probably like 10 times with 3-5 different errors, including I/O errors and causing my MBP to hard-reboot while trying to perform tests - which made me think that there was a HW issue with my MBP's disk controller/cable etc. - turns out there isn't, as you'll read along, you'll see that it works completely fine with the original HDD that came with the MBP - man, scary stuff had happened that I never saw on a MBP so far, I felt so close to getting the BSOD :-P on a Mac!)

- By the way, all these behaviour is completely the same on both SSDs after the upgrade to 10.11.4, and again, one of them was a brand new one which was basically sitting on the shelf since I was too lazy to install it onto my desktop... And before the upgrade, I used the first one on my MBP without any problem for around at least 6+ months...

- I also got some weird icons literally flickering at the boot phase, they were the "Prohibitory symbol", "Folder with a question mark", "Apple logo", "Progress indicator", "Login window", etc. You can see all of them on: 

- And this SSD works completely fine on my desktop or when used as a non-boot external attached drive on the MBP (with the help of a disk enclosure with a USB interface).


Just putting this here so someone on the web who will (in my opinion, as more people upgrade) eventually face this issue can maybe find this and plan accordingly...


So how did I solve the issue? I just used the original HDD that came with my MBP, everything is now okay...


On the SanDisk SSD Plus 240 GB (bought from, I had trouble installing with error messages like "An error occurred while updating system extension information." and many, many more... I am simply too tired to document them all as one can only imagine how many errors one could face on a 3 day journey to fix this issue... But I might try later if I find the power to do so...


So basically, nearly all of the error messages that I received ended up getting me into "Hackintosh" websites where people were complaining on their Hackintosh not booting after some update, some device not working, etc... That's why I'm thinking that this has something to do with Apple's 10.11.4 update putting some restrictions on the hardware so either people has to use genuine stuff or they are simply trying to patch possible security exploits. But I assume it's the first one...


Alright, this is all I can share at the moment... Feel free to share your comments and I might try to provide more information about what I went through, if someone needs it.


Note: I think that this should also concern SanDisk as I usually see MANY MANY people providing reviews on about the performance of these SSDs on their MacBooks... If apple closes this door, it might hurt SanDisk in the end... I hope this will never be the case though...


Cheers! Have a great day...

SanDisk User
Posts: 44
Registered: ‎03-16-2015

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

I've not had any issues with my early 2011 MBP + Samsung PRO 850, nor is the SanDisk Extreme Pro SSD in the DVD bay having any issues at all with 10.11.4.



Did you...

removing the SSD and hook it up to another Mac and use Disk Utility to repair the disk

try booting into safe mode to see if this is doable?

enable TRIM?  (prior to 10.11.4) With El Capitan, you can manually enable TRIM with 3rd party SSDs.

making a bootable flash drive installer to install 10.11.1/2/3?

using DiskWarrior (in the event the install caused a corruption)?

reverting back to a carbon clone prior to 10.11.4?

running AHT or any program that can pull SMART data to see if the SSD may be failing?


Based on the errors, it seems very possible that the SSD is failing or there is some type of major corruption beyond what the DiskUtility app can repair. If you have a friend with DiskWarrior and/or DriveDX, you can pull some data that might better explain what is happening

Posts: 2
Registered: ‎04-18-2016

Re: Dose SanDisk SSD Plus 240GB work on macbook pro late 2011

Hey, long story short, it was not the SSD. It was the HDD cable that connected the SSD to the logic board. Apparently, these MBPs are notorious for their failures with the HDD cable going bad. In fact, if you go to and look up the most popular replacement parts for this model, you'll see the HDD cable topping the list, followed by the battery, etc. :-). I've spent many more hours in researching this issue after my first post above, then found out the guilty part and ordered a replacement. Knocking on the wood, it's been around a week without any issues at all, no matter how hard I tried after I replaced the defective cable with a new one.


Now to your questions, here we go;

- I've tried connecting it to my PC and used SanDisk's SSD Dashboard etc. utilities to see if the disk was faulty, none reported any errors for any of the SSDs. However, I didn't have a spare Mac to use to test with Disk Utility. My test with Disk Utility on the Mac that had this defective cable failed often with I/O errors being reported. Sometimes Disk Utility failed to see the disk at all.

- Tried booting into safe mode (with Shift key) and wasn't able to (before finding out it was the cable).

- TRIM was already enabled on my MBP/SSD before the HDD cable went nuts. Yes, OS X recently added the support to enable TRIM for 3rd party drives.

- Yes, I've tried making a bootable HDD and a flash drive and succeeded. However, fresh OS X installation usually failed close to the ending, due to I/O errors with the SSD.

- I was able to recover my data by booting from the old, original HDD that shipped with my MBP, then, plugging the SSD through a USB interface with the help of an external disk enclosure, than accessing it and finally copying the data to an external HDD. The reason I was able to boot with the original old HDD was that SSDs were much more sensitive to I/O errors and to my luck, the old HDD lived long enough with the defective cable to complete the recovery process :-). After some fiddling with the cable, it went complete haywire and after a certain point, Disk Utility was no longer able to see any of the drives at all (RIP defective cable). I was lucky because the SSD was encrypted and it was nearly impossible to plug it into a USB port of a Windows PC with an external disk enclosure and enter the encryption password to "unlock" it and then access the data. If the cable didn't made it and went haywire before the recovery, I probably would had to find another Mac user that I can use their Mac to attach my SSD and copy over my data... Because the moment I attached the encrypted SSD to my MBP, OS X was clever enough to see that it was a disk it encrypted before and prompted me to enter the encryption password to literally "unlock" it. And it worked flawlessly. Windows was not able to understand what type of file system or data the drive contained at all. And I've tried a few software to simulate OS X behaviour in the hopes that it could help me emulate OS X and access the data through Windows, and all failed.

- Unfortunately, I had no backup at that time to revert to a previous OS X version (yes, stupid me... :-)). But this was a good lesson learnt for me. Now I'm keeping hourly, weekly and monthly backups through OS X's Time Machine over wi-fi to my Network Attached Storage :-). No more "stupid me"s :-).

- As said above, when plugged with an external disk enclosure over USB to my Windows PC and testing with SanDisk's disk utility apps (like SanDisk SSD Dashboard etc.), SMART data was telling me that everything was fine. And the SSD passed all of the health tests successfully. I also ran AHT (Apple Hardware Test) by booting from an external USB drive that I created that contained AHT. And my MBP passed AHT's extended test without any errors at all (took like an hour or so).

- Phew... :-)


Other than these, I appreciate your suggestions, and if you have read this through, I appreciate your time as well. But I'm giving out these details more like in order to help someone that might experience a similar issue and could Google this and come up with this post and save some plenty amout of time! :-) It took me like a week to find out the faulty part and replace it. As you can see above, it was a lot of pain in the a** to go through all the troubleshooting I did :-).


In the end, it was purely my bad luck to experience this failure right after an OS X upgrade (literally within minutes), which led me to falsely believe that it was the culprit - being the last change made.


Anyway, hope this post will be helpful to someone else :-).



Posts: 3
Registered: ‎04-07-2017

Re: Does SanDisk SSD Plus 240GB work on Macbook Pro late 2011

[ Edited ]

I have a MacBook Pro Early 2011. And I upgraded the drive to this Sandisk: 


Capacity: 960.2 GB (960,197,124,096 bytes)

  Model: SanDisk Ultra II 960GB                  

  Revision: X41100RL

  Serial Number: 162280420752

  Native Command Queuing: Yes

  Queue Depth: 32

  Removable Media: No

  Detachable Drive: No

  BSD Name: disk0

  Medium Type: Solid State

  TRIM Support: No

  Partition Map Type: GPT (GUID Partition Table)

  S.M.A.R.T. status:


Note it says TRIM Support: No


But despite that can I activate the Mac OS TRIM support and will it owrk with this drive? Anyone with exprience with switching on TRIM on this Sandisk drive?