Reply
tyl
Newbie
Posts: 2
Registered: ‎04-13-2016

internet explorer required for SSDDashboard :((

[ Edited ]

Hey guys.

 

Ive just cloned and moved from my old 120gb corsair force 3, to a 480gb sandisk ultra II and found that I need to install Internet Explorer 9 or higher to install the ssd dashboard. Why??

 

- Its very disappointing considering how poor IE has been with regard to security issues to the extent that even governments have even urged users to switch to something else from time to time.

 

http://www.zdnet.com/article/governments-urge-internet-explorer-users-to-switch-browsers-until-fix-f...

 

Plus, the many users who have deliberately removed IE for the above and others reasons, now have to increase the vulnerability surface of their systems (not to mention the inconvenience) merely to check/update the firmware on their ssd? Sigh...

 

Can you please remove the requirement for IE to install/use the dashboard asap. Keeping it is kinda poor form guys.

 

thanks, -tyl

VIP
Posts: 148
Registered: ‎01-24-2008

Re: internet explorer required for SSDDashboard :((

The minimum requirement in order to install SSD Dashboard is IE 9. The IE engine is used to render the UI so it is an essential component. It is up to you if you want to use or not the IE browser. You may as well un-installed it, but Windows will always have the IE engine installed because Windows is also using it other then just for Browsing. I suggest you install IE 11 and un-install the Browser. That way you upgrade your engine and you still not using IE browser.

Newbie
Posts: 2
Registered: ‎05-10-2016

Re: internet explorer required for SSDDashboard :((

+1 

I'm using Google Chrome and don't want they insist on IE.  I bough SanDisk SSD and isn't it enough to avoid me from annoying Microsoft marketing ?

VIP
Posts: 148
Registered: ‎01-24-2008

Re: internet explorer required for SSDDashboard :((

arctic51                   

 

If you use Microsoft Windows OS, IE engine is embedded into the OS. Maybe you should use MAC OS or Linux.

 

Newbie
Posts: 2
Registered: ‎05-10-2016

Re: internet explorer required for SSDDashboard :((

Im using Windows, but not launch IE even once. Just install other browser from .exe file. Don't want those spy from cia or any other authorities collect my info and read messages. So i can't use SSDdashboard ((( 

tyl
Newbie
Posts: 2
Registered: ‎04-13-2016

Re: internet explorer required for SSDDashboard :((

George, youre wrong.  I run windows 7 Ult x64 and never needed or had installed Internet Explorer until SanDisk SSD Dashboard required it for its installation.

 

Youre suggested solution not to buy Sandisk SSDs for a windows pc is lame and unhelpful. 

 

Certainly, I wont buy sandisk again.  Back to corsair for me.

Highlighted
VIP
Posts: 148
Registered: ‎01-24-2008

Re: internet explorer required for SSDDashboard :((

Tyl,

 

Windows 7 comes with IE (engine) version 8 or lower, which has some critical bugs.

SSD Dashboard is asking the users to upgrade to a newer version of IE. You can uninstall IE right after it, the engine will remain.

There is nothing personal here. If you want to use SSD Dashboard you will need to have a newer IE engine installed.

SanDisk Guru
Posts: 4,460
Registered: ‎07-18-2007

Re: internet explorer required for SSDDashboard :((


arctic51 wrote:

Im using Windows, but not launch IE even once. Just install other browser from .exe file. Don't want those spy from cia or any other authorities collect my info and read messages. So i can't use SSDdashboard ((( 


The CIA is not relying on IE to spy on people. If they want your data they will get it whether you have IE installed or not. Also as georgealon has said you can uninstall it right after the dashboard is installed but regardless you will not be able to use the dashboard if the IE engine is not there.