Reply
Newbie
Posts: 2
Registered: ‎12-29-2014

Re: firmware update problem

Just an update: An email to Sandisk support got me advice to reformat the drive and try again. I did so, and had the same result. So I called them and after a morning of back and forth, they could not solve the problem. They offered to replace the drive if I send it to them (their cost; my wait). They did not explain why the firmware upgrade won't take, but were keen to get the (barely readable) serial number and hinted that it may be a compatibility problem with the driver on some units, if that makes any sense. So I guess I'll be sending mine in for replacement. I would just use it as is (it seems to work fine in every other way), but am concerned that if it won't take this update, it won't take future ones, either. Good luck!

Newbie
Posts: 1
Registered: ‎01-05-2015

Re: firmware update problem SOLVED

Hi everyone, I had the same issues that everyone has been describing here but after much stuffing around, I have a solution.

 

1.   Connect to the drive by WiFi through the app > make sure internet pass-through is enabled > disconnect

2.   Connect by USB to computer.

3.   Download the firmware upgrade file and copy to the root of the media drive

4.   Eject the drive from computer.

5.   Reconnect COMPUTER to media drive by WiFi.

6.   Access web-app through a browser.  192.168.11.1

7.   Go to Settings

8.   Log into Admin area

9.   Click on Upgrade Media Drive

10. In the modal popup window click on Upgrade.

 

The Media drive will now upgrade firmware and reboot.

 

In the Android and iOS Media Drive app you will still get a notice saying a firmware upgrade is available however the web-app will now confirm that the latest firmware has been installed.

 

A bit of stuffing around but a result at least.  Certainly quicker than returning your drives to SanDisk!!

 

Hope you find this works for you too.