Reply
Highlighted
Newbie
Posts: 3
Registered: ‎02-17-2020

Clip sport not working in one pc

I have a Clip sport I was working on my main pc.  Now when I plug it in, it will say traferring, and then go to the main screen on the MP3 player, and doesn't show as charging.

 

When plugging it in I will see it show up under USB as a Mass Storage Device, and I will also see it show up twice under the Disk Drives this is for about 5-10 seconds at max, it then will remove itself from both areas in Device manager.  It will not see the device, and will not charge it.

 

If I plug it into another windows 10 computer, it works fine without issue.  So I know it's not the device or the cable, it appers to be something with this main PC.

 

Any help would be appreciated.

 

Thanks.

Highlighted
Newbie
Posts: 3
Registered: ‎02-17-2020

Re: Clip sport not working in one pc

Ok, I rebooted the computer, and the Sport Clip is coming up as the H: Drive.  new message -> "This file does not have an app associated with it for perfomring this action.  Please install an app, or if one is already installed, create an association in the Default Apps setting page."

Highlighted
SanDisk Professor
Posts: 613
Registered: ‎09-12-2015

Re: Clip sport not working in one pc

My favorite advice is to make sure you are using a micro USB cable that is capable of charging AND data transfer.  This type cable is not typically sold in $1 Stores, $5 Stores, etc.  The SanDisk  package includes a short version of the required cable. 

My old Garmin GPS came with a data transfer micro cable. I have at least a dozen more that do not work for my Clip Sport. 

 

Also, maybe try re-booting the PC.  Also, maybe try each available USB port on your computers. 

Highlighted
Newbie
Posts: 3
Registered: ‎02-17-2020

Re: Clip sport not working in one pc

The cable is fine, as I used it on another computer, and it works just fine.  The device is working also, since it works on another computer.  I already rebotoed and recevied that error message.  I'm thinking it's something about my main computer got munged up, and It's not working.  It does the same thing on all USB ports on the main computer, but a couple of the ports, it will show up longer, up to a 1 minute before it disconnets itself. 

 

Also might be a Registry properly, I'm working on a in-place upgrade possibly.

Highlighted
SanDisk Professor
Posts: 613
Registered: ‎09-12-2015

Re: Clip sport not working in one pc

[ Edited ]

Hopefully you will find a helpful video on YouTube. Here are links to 2 videos I found.

One provides some useful advice for restoring the USB Drivers The other discusses restoring a Storage Device drive letter.

 

https://www.youtube.com/watch?v=rQI8qXzWJX4 

 

https://www.youtube.com/watch?v=ldFZrRLn9T8