Reply
Newbie
Posts: 4
Registered: ‎04-02-2016

Clip Sport not booting after FW update

Hello!

 

I have downloaded the FW update version 1.29 to upgrade from 1.22.

First I tried to update it via updater program. It was already suspicious, that it only offered manual for downloading.

After that I tried manual upgrade as described in the instructions.

I got some sort of update failed message on the screen, after that it booted.

I held down the power button for 15 seconds to reset just in case.

After that the device only shows SanDisk logo on the screen for some seconds, then blanks out/shuts down.

When the USB cable is attached, it keeps the logo on the screen and nothing else is happening. Also, the PC is unable to detect the device.

Tried: resetting and holding down power and then attaching to USB.

 

Any ideas? I really liked this player and it would be nasty to have it bricked with so little effort.

 

Thanks in advance!

SanDisk Guru
Posts: 16,301
Registered: ‎04-17-2008

Re: Clip Sport not booting after FW update

If it will still connect and be regognized by your computer, I would:

 

1.) Manually re-install the firmware again. If this doesn't help, then . . .

 

2.) Format the player (note: this will erase all music, etc. files you put on it, so you will have to re-load after).

Newbie
Posts: 4
Registered: ‎04-02-2016

Re: Clip Sport not booting after FW update

Thanks, but none of it applies.

I described all the symptoms above and there's no way to do any of what You  suggested.Otherwise, I would have tried them.

I backed up the data and formated the player before the FW update. Maybe I should have resetted it before running the update, also.

One other thing I could try, is to put the update hex to the SD card and try to boot from that. Not sure, if the player manages, though.

Will tell later, how it went.

Newbie
Posts: 4
Registered: ‎04-02-2016

Re: Clip Sport not booting after FW update

I tried to put the update.hex to the root of an SD card.

Nothing. The system either is not meant to look for other mount points or is corrupt and fails to do so.

Next step is to solder the battery wire off and drain the voltage via power button.

This won't help most probably, but nothing to lose.

Newbie
Posts: 4
Registered: ‎04-02-2016

Re: Clip Sport not booting after FW update

Confirmed: Disconnecting the battery is not helping.

 

I would assume, the filesystem is corrupt. Any way to reinstall the system?

Newbie
Posts: 1
Registered: ‎05-01-2016

Re: Clip Sport not booting after FW update

I have encountered exactly the same issue and still wait for someone to come up with a working solution. Can't believe that tech support has not picked this up, yet. 

Newbie
Posts: 5
Registered: ‎09-16-2019

Re: Clip Sport not booting after FW update

I added the .hex file and then my player updated the firmware all the way up to 90% then stuck there. Did a reboot now it won't turn on at all. Computer wont recognize it either.
SanDisk Professor
Posts: 578
Registered: ‎09-12-2015

Re: Clip Sport not booting after FW update

This situation is a bit challenging to resolve.   I am hoping Tapeworm, our SanDisk Senior Guru, will soon provide some expert advice.    While we are waiting try these quick ideas:

    1. Player not connected to PC, press the large oval button for 20-25 secs and see if the player starts up.

    2. Player connected to PC, same as #1.

 

 

 

 

Highlighted
Newbie
Posts: 5
Registered: ‎09-16-2019

Re: Clip Sport not booting after FW update

This solution worked for me. It allows one to use a separate program to force a firmware onto the device then you can copy the latest version 1.43 upgrade.hex file to the root directory and update the entire system. Worked like a charm for a clip sport mp3 player that was completely dead and unresponsive to any of the conventional reset methods.
https://sandisksportfirmware.wordpress.com