Reply
Newbie
Posts: 2
Registered: ‎03-10-2018
Accepted Solution

No Album Art Showing

I can't get album art to show up on my player. I am transferring from iTunes to the player (drag and drop) and the music transfers just fine but no art will show up.

 

After trolling forums I've tried all of the following:

Updating the Sandisk firmare

Converting the ID3 tags to v.2.3 (also tried v. 2.4)

Making sure my images are perfect squares

Making sure my images are below 100kb

Adding the image as a seperate file names "album art.jpg"

 

Still no album art on my player. Everything looks great on my computer but it will not show on the actual player. Help?

 

Screen Shot 2018-03-10 at 12.32.14 PM.png
SanDisk Professor
Posts: 540
Registered: ‎09-12-2015

Re: No Album Art Showing

[ Edited ]

With the helpful information in this Forum and a lot of trial & error, I figured out a way to get album art displayed on my mp3 files with my Clip Sport (non Plus version). I use the software "mp3tag". Maybe it is also possible using iTunes or many others ??

 

1. I use ID3 tag version 2.3 and I delete all other tag format data from the mp3 files (v2.1, v2.2, v2.4, APE, etc).

       I use ID3 v2.3 (ISO-8859-1).

2. I use jpg album art files that are approx 250 x 250 pixels and 72 DPI. When saving the jpg file. I clear all "EXIF" data (if exist).

3. I make sure all current embedded album art is deleted from my mp3 files. Then I embed one 250 pixel jpg file into the mp3 files.  

4. A handy trick with SanDisk players is to delete all embedded art from a subfolder of mp3 files. Then you can save one corresponding album art file as "folder.jpg" in the same subdirectory with the cleaned mp3 files.

 

Random Notes:

->Sometimes just deleting all non-v2.3 tag data will do the trick of displaying the current embedded album art. (Yay !!)

->PNG album art does not work for me.

->Large size album art (default from iTunes) does not work for me.

->There is a whole alternate reality of details to get album art to display with "m4a" files that use ID3 v2.4 data.

SanDisk Professor
Posts: 540
Registered: ‎09-12-2015

Re: No Album Art Showing

AND, another thing.....

Are you using a Mac computer to curate your mp3 files and album art files?

That is a whole other world of fussy details that really delayed my full enjoyment of my Clip Sport.

   ( I ended up using my favorite MS Win apps with my Mac Mini using WINE Bottler.)

Newbie
Posts: 2
Registered: ‎03-10-2018

Re: No Album Art Showing

Thank you so much for all your advice. I tried several of your suggestions (though a few like the EXIF extension I don't know how to do).

 

What I DID do that worked was found ONE photo that worked for whatever reason, then copy and pasted every other graphic on top of it in a photo program and saved it, then reassigned the graphic in iTunes. That seemed to work (took four hours to get through them all but it's done!)

 

and yes it is a mac Smiley Happy

Newbie
Posts: 5
Registered: ‎01-09-2019

Re: No Album Art Showing

Hi there…

Would you please help me in trying to figure out why some art work I attach to my MP3 music using mp3tag v270 and the upgraded v291 does not show when copied to my Sony ZX300 Walkman, my system is: windows 10 on a brand-new laptop.

https://www.sony.com/electronics/walkman/nw-zx300

Knowing that it is happening to some pictures that are .jpg and .jpeg

The strange thing is: I have done some test using other ID tag writers other than mp4tag (over 5 other software) by

  1. Re-adding these art work to the mp3 files on my PC.
  2. Going to the MP3 player and deleting these files before adding the new once.

 

Same problem, doing this still does not fix the problem!!

 

The other strange thing is: I use windows media player when I play music on my PC, for some reason the windows media player sometimes gets confused displaying different art work that belongs to other files that was played on it before, closing the player, re-open and re play the new file again will display the right art work for that MP3 file.

Highlighted
SanDisk Professor
Posts: 540
Registered: ‎09-12-2015

Re: No Album Art Showing

[ Edited ]

Whoa !!  You are asking for help with your Sony MP3 player from users in the SanDisk Forum ??

I have not seen any discussions of the Sony Walkman players within this Forum.

 

GENERAL ADVICE FOR SANDISK PLAYERS

1. For my SanDisk Clip Sports I always use ID3 tag version 2.3 and I delete all other tag format data from my mp3 files (v2.1, v2.2, v2.4, APE, etc).  I use ID3 v2.3 (ISO-8859-1).  I use the software "mp3tag".

2. I use jpg album art files that are approx 250 x 250 pixels and 72 DPI. When saving the jpg file. I clear all "EXIF" data (if exist).

3. I make sure all current embedded album art is deleted from my mp3 files. Then I embed one 250 pixel jpg file into the mp3 files.  (Maybe the player will get confused with multiple embedded art files??)

4. A handy trick with SanDisk players is to delete all embedded art from a subfolder of mp3 files. Then you can save one corresponding album art file as "folder.jpg" in the same subdirectory with the cleaned mp3 files.

 

Random Notes:

->Sometimes just deleting all non-v2.3 tag data will do the trick of displaying the current embedded album art. (Yay !!)

->PNG album art does not work for me.

->Large size album art (default from iTunes) does not work for me.

->There is a whole alternate reality of details to get album art to display with "m4a" files that use ID3 v2.4 data.

 

FINAL IDEAS

If you have a few mp3 files that properly display their embedded clip art, then try to identify the exact ID3 tag properties of these files and the exact properties of their embedded clip art file ??

 

I like to use the program "irfanview" to adjust my clipart files before embedding into mp3 files.

     https://www.irfanview.com/

 

 

 

Newbie
Posts: 1
Registered: ‎02-21-2019

Re: No Album Art Showing

I tried resizing jpg images and it worked for some images and not others. I really don't understand why. I did the exact same thing to all the song's cover art, and some  work and some don't. Even songs in the same album with the same exact photo vary between showing and not showing. Please help.

Thanks