Reply
Newbie
Posts: 2
Registered: ‎10-26-2019

Poor Audio Quality?

[ Edited ]

I recently got this as a replacement to a broken sport plus. I have noticed that on some songs there is very poor sound quality in certain sections, like the player cant play certain sounds correctly. I'm not entirely sure how to describe it, its kind of like when you turn the volume to way higher than a speaker can handle and it muffles/crackles. However it happens at any volume and on any headphones. Its not random, always the same problem in the same places on the same songs. I've tried different equalizer settings and it didn't help.

 

It isn't a problem with the MP3's, they play fine on other devices and the exact same files had no issue on the Sport Plus.

 

I have updated to the latest firmware but that also made no difference. Anyone have any idea's on how to fix it? I can't return it as amazon have sent me a warning about returning too many items in too short a time so I'm stuck with this thing as it is.

 

Another issue that I'm not sure was just a randon glitch or not was that when I turned on the player, the battery went from full too "battery low" in the spand of around 5 seconds just while in the UI, no music playing. 

SanDisk Guru
Posts: 16,310
Registered: ‎04-17-2008

Re: Poor Audio Quality?

[ Edited ]

Sounds like a dud to me. I doubt there's any way to remedy this other than returning & getting another. Maybe try to get it replaced from SanDisk directly instead of Amazon?

 

You could also format the player, reload the content & cross your fingers for luck.

Newbie
Posts: 2
Registered: ‎10-26-2019

Re: Poor Audio Quality?

Probably is a dud as you say. However I've already wasted enough money on this thing without the expense and hassle of having to post it to god knows where. I'd also be really annoyed if I did that, got another back and it turns out its just that this model sucks and they all do it. I really wish there was a reasonable alternative that supported Audible. Since my original Clip+ the Sandisk players seem to have gone steadily downhill. I really miss the clip+.