Reply
Highlighted
Posts: 0

New 16GB cruzer problems

OS: Win XP, home ed, sp3

 

Hello:

 

I just bought a 16 gb SanDisk Cruzer at Amazon.  The thing is acting so weird it's difficult to describe.  I have several other flash drives that work perfectly so I doubt it's my computer.  

I formatted the new Cruzer then copied some photo files to it.  Right away I noticed a few of the files did not show a thumbnail image - just the JPEG icon and title.  Those "imageless" files cannot be opened by any app.  Then I created a few folders in the Cruzer and suddenly dozens of folders and files appeared with weird codes like this: φ┴?7ßE⌡┐.ÿu£ & 8p┴x9=a.¿B▒  These weird folder/files could not be opened or deleted!  Then I tried to re-format the Cruzer and it would not allow a format!  I tried to unplug the Cruzer with windows "Safely remove" app. but the Cruzer would not allow it!  Finally, I turned off the computer, unplugged the Cruzer, re-started the computer, plugged back in the Cruzer and to my surprise the Cruzer began working correctly.  I formatted it and began moving files to it.  All was well, then suddenly it began acting weird again - showing bad JPEG images, automatically creating mysterious folder/files.  This time, however, the Cruzer allowed formatting, safe removal, but the mystery forlders/files cannot be opened or deleted (except with a format)!  Right now the Cruzer is plugged in but I am reluctant to use it any more until I learn how to either repair it or use it free of weird automatic folder/file tampering or making bad JPED images.  Oh, and I ran a chkdsk/f on the Cruzer - it's OK.  I even ran a virus scan to see if a virus is causing this - but you'd think my other flash drives would be effected but they aren't.

I appreciate any ideas or feedback about this weird Cruzer

thanks

jim