Reply
Newbie
Posts: 3
Registered: ‎01-12-2017

Re: 128gb SDXC micro sd problem! Help me find out what happened to it please!

I was able to format my card eventually....

 

I had searched and tried many ways including formatting via command prompt, formatting through my android and formatting through windows.

 

When trying to format with windows it would only give me the option to format it at 27gig.

 

In my android device it said that it successfully formatted and appeared to 64gig. however when connecting to USB in window it was still only 27gig. 

 

 

I finally got it to format using the DJI OSMO UHD camera whilst connected to a USB port with Windows 7. upon connecting to windows through the camera, windows prompted me to format it and it allowed the full 64gig to be formatted... That's it!

 

I hope it helps someone out as I was almost going to try and get sandisk to replace it.

 

Good luck!

 

Newbie
Posts: 1
Registered: ‎04-15-2018

Re: 128gb SDXC micro sd problem! Help me find out what happened to it please!

Hello respected ,
I have purchased 128gb 10class sd card i used it for 2 day but at last when i inserted in my phone its not showing any sd card...
After that i inserted this sd in Windows 7 PC with card reader but is aslo not showing....
What should i do?
Please reply me i am worring
Newbie
Posts: 1
Registered: ‎01-07-2019

Re: 128gb SDXC micro sd problem! Help me find out what happened to it please!

Ok, here's a thorough guide I made due to an issue I had that was resolved after this procedure. You will need a 4 GB usb stick, Rufus, the latest Ubuntu ISO file and SD Formatter.

Optimally, you want a direct SD slot to use via an SD adapter card. Avoid cheap USB adapters and use one that supports USB 3.0 or 3.1. A Kingston or SanDisk adapter (or one of similar quality) will likely be your best bet if you do not have an SD reader in your computer.

This will require you to reformat the SD card so backup any data beforehand if possible.

 

This is the Ubuntu Live method. Alternatively, you can use a Windows based application if it is able to create GPT partition tables for an SD card and skip straight to step 11.

 

  • Step 1: Get your hands on a 4 GB or larger USB stick. Alternatively you can burn a DVD if you have those resources available.
  • Step 2: Download the latest version of Ubuntu and Rufus.
  • Step 3: Launch rufus, select the ubuntu iso file and make sure you have the correct USB stick selected in case there are multiple plugged into your computer. Then run the procedure and it will create a bootable Ubuntu Live usb stick.
  • Step 4: With the boot-stick done, restart your computer and boot from the usb. UEFI or Legacy really doesn't make much of a difference for this procedure but if UEFI is available, I would go with that one.
  • Step 5: After booting from the USB, select "Try Ubuntu" which should be the top option.
  • Step 6: Once Ubuntu has booted up, connect your microSD card with an adapter of your choice, USB or SD adapter directly into an SD slot.
  • Step 7: Click the bottom left icon that looks like a grid of squares, search for "Gparted" and run that application.
  • Step 8: In Gparted, find your SD reader or USB adapter and select it if it is not already selected.
  • Step 9: Press the Device dropdown menu and Create Partition Table.
  • Step 10: Select GPT and hit ok.
  • Step 11: Once it's done, you can restart the computer by clicking the top right power icon in the user interface and from there restarting the machine.
  • Step 12: After you boot back into Windows, download and run SD Formatter, format your microSD card with exfat for smartphone use or NTFS if you have a Windows device you want to use it with.

A lot of steps, I know, but it did resolve my issue entirely. Hope this helps anyone out there experiencing SD card issues.

 

Newbie
Posts: 1
Registered: ‎08-13-2019

Re: 128gb SDXC micro sd problem! Help me find out what happened to it please!

I have an old Dell laptop running Vista.  I got a 128 GB card from Amazon which would only format 24GB.  Thinking it might be related to the system or computer, I took my laptop to Best Buy and bought a new 128GB card.  In the parking lot, I tried the card in my laptop and it would only see 24 GB.  I took the card back in the store and had them place it in their computer's SD slot and it saw around 120 GB available, making me think that it might be the machine/software and not the card causing the problem.

 

I am planning to use the cards in my other computer which is around 10 yo, but runninng Windows 7, which unfortunately is currently not working due to being about 30 feet from a lightning strike about three months ago.  I have determined the hard drives are good, but need a new motherboard.

 

If I still have problems, then I will try some of the above suggestions.