Posts: 0
Accepted Solution

Extreme IV Reader problems

  I just bought a SanDisk Extreme Firewire CF card reader and although it is recognized by my Windows XPsp2 system, when I attempt to read the CF card I receive an I/O device error.

Any ideas??

I know the card is good.  I tried uninstalling it from dev man and letting Win detect it after a reboot, but same thing.  When I first plugged it into my system, I had a WD MyBook connected to another Firewire port, but I have since moved it over to USB2 connection.

Should I see this FW drive in my list of of removable drives when there is no card inserted?  I am not currently seeing this with this reader, but my internal USB card reader does list the drives for the various slots.

Thanks in advance.


Message Edited by jerumball on 01-03-2008 11:26 PM
Posts: 0

Re: Extreme IV Reader problems

You should not see the FireWire card reader under My Computer until you have a memory card inserted. 

As for your computer, is the FireWire port built into the computer, or is it an expansion card. 

Do you know if the FireWire port provide power?

Also, is it 6 Pin or 9 Pin?
Posts: 0

Re: Extreme IV Reader problems

Thank you for your response.

The firewire ports that I tried were built in to my HP v7580n desktop.  I tried both the front mounted port and the one on the back to no avail.  The ports were 6-pin and they powered up the reader just fine (the blue LED lit up when a card was inserted).

I have since talked to SanDisk tech support and they concluded that the device must be defective and thus suggested I return it to where I bought it, which I have done.

Before I sent it back I was thinking about buying a a firewire expansion card to try, but decided against it.  Do you think that would have helped?

Thanks again.
Posts: 0

Re: Extreme IV Reader problems

I had exactly the same problem, got the same result from SanDisk tech support, bought an expansion card, and now the reader works just fine.