Posts: 0
Accepted Solution

U3 Stuck on "Initializing"

I have a 4GB Sandisk Cruzer Titanium with U3. The U3 software works fine on all my PC's at home and most at work.
There are 2 PC's at work I cannot get U3 to complete. When the drive is inserted, Windows XP beeps and U3 launches but then hangs on "initializing". I have the latest U3 software, there is no problem with the drive letters on either machine. They are both "Fujitsu" PC's all the others (which do work) are "Dell". All machines are networked (large hospital). There does not seem to be a problem with network drive letters.
The U3 gets allocated drives D and F, (E is the CD Rom),  R is  the network drive.

I need this device to function at work any help appreciated.
Posts: 0

Re: U3 Stuck on "Initializing"

I am running the cruzer micro 4gm (black and sliver) with U3 It also locks up on startup. Software that may be in conflict is NERO 8 or MS Office 2007. I notified support,
Posts: 0

Re: U3 Stuck on "Initializing"

I noticed that some programmes conflict with the U3 software, except neither of the 2 programmes you mention are on those 2 troublesome PC's.
Posts: 0

Re: U3 Stuck on "Initializing"

Have you tried allocating different drive letters when on the Fujitsu machines?

Posts: 0

Re: U3 Stuck on "Initializing"

I found my problem to be MUSICMATCH JUKEBOX 10.0 The SanDisk Cruzer Micro 4gb  U3 works just fine with the musicmatch jukebox removed from my startup file.


Received this from tech. support::

Hello Gary,

Thank you for contacting SanDisk Technical support. It is our goal to make sure that you have all the resources that you need to make the most out of your product.

I have received your email and I understand that you are having difficulties in using the Cruzer. Rest assured that I will do my very best in resolving this issue.

Please let us verify the operating system that you are using, your computer's make and model, and the manufacturer of your computer.

Please unplug the flash drive, reboot your computer and plug the cruzer back in. If the matter persists, let us try another PC, preferably one outside of your present environment (if you are using the device in office, try it at home, or vice versa) but, again, one on which you can gain full administrative rights to.

If it works well in other computers, then we may need to try some simple tests.

Let us be sure to try all of the USB ports on your machine, both forward and rear. Does this yield a different response? If not, let us move on.

Next we would want to try disabling all of your items on "Start-Up". Start-Up items are pieces of software that run automatically whenever your PC is first turned on. Certain pieces of software are prudent, in general, to have on start-up (e.g. Anti-Virus software), while other softwares are more menial in scope (e.g. AOL Instant Messenger). Since all programs can be manually started, in general, the only softwares we want in start-up are programs that we know that we are going to use everytime that we use the computer and would, thus, prefer that they start automatically.

To disable your start-up items, SINGLE LEFT CLICK on "START", then SINGLE LEFT CLICK on "RUN" from the menu that appears. When the "RUN" dialog box appears, please type "MSCONFIG" into the "OPEN" field, then press the "ENTER/RETURN" key on your keyboard. This will bring up your "SYSTEM CONFIGURATION UTILITY".



you will notice two buttons at the bottom that say "ENABLE ALL", and "DISABLE ALL". We, of course, are going to be SINGLE LEFT CLICKing on the "DISABLE ALL" button, and then SINGLE LEFT CLICKing on the "OK" button at the bottom of the SYSTEM CONFIGURATION UTILITY window.

A prompt will appear on your screen saying; "SYSTEM CONFIGURATION: YOU MUST RESTART YOUR COMPUTER FOR SOME OF THE CHANGES MADE BY SYSTEM CONFIGURATION TO TAKE EFFECT". Please ensure that your flash drive is not plugged into your computer, then SINGLE LEFT CLICK on the "RESTART" button, and allow your PC to totally reboot. Once your PC is back up and running, let us plug the flash drive back into your PC, and see if the problem persists.

If not, let us simply reload each of our start-up items, one at a time (restarting your PC in between each, always unplugging the flash drive first), until the error repeats itself. Once the error repeats itself, we will have found the conflict.

If the error persist, let us move on by disabling any firewalls and Anti-Virus software that you may have running on your computer. If you are concerned with getting a virus or such during this process, you may simply disconnect your computer from the Internet, as it will not be necessary for any of our troubleshooting steps.

Once you have disabled all of the securities on your PC, please reboot and, again, once back up, reinsert the flash drive back into your PC. The same here: If it solved the issue, reinstitute each item one at a time until we is cover the culprit.

If the device fails in all of these testings, please unplug all other USB devices, reboot the computer and plug them back one by one starting with the flash drive.

Please advise.

If applicable, please take a moment to update your eBox account at This will register your product as well as facilitate the warranty replacement and technical support process in the future. When you update your eBox account, please include the place and date of purchase of your product. This will enable us to better assist you should you need to contact us in the future.

Should you have any other concern with our products, please reply to this email.

Best Regards,
Andrew G.
SanDisk Technical Support

Posts: 0

Re: U3 Stuck on "Initializing"

I have this same problem with about 20 pcs at my work place.  I believe it is related to software we have called "DeepFreeze".  This is excellent software that prevents viruses, spyware, etc.  However, nobody is able to use an U3 enabled USB drive, because it just stays stuck on "Initializing".