Reply
Posts: 0

Re: No Drive Letter

I have a Cruzer 8GB that I have been fighting for weeks or months. I have forgotten how long... I have Windows 7 at the present time but have fought this on Windows Vista as well before I got 7. I get the same error message that was posted at the top of this thread.

 

"Windows has allocated a drive letter to the U3 drive that is already taken by another drive on your machine or there are no more drive letters available on this machine. Try disconnecting any network drives that you have connected to your computer and restart U3 by double-clicking LaunchU3.exe or the U3 System CD-ROM icon. Once the U3 Launchpad is running, you can reconnect the network drives.

If you do not have administrator priviledges that allow you to disconnect network drives, contact the system administrator.

 

For more troubleshooting tips click the Troubleshoot button."

 

I have given the Cruzer the next two places after my 2 DVD ROMS which are G and H. I have other network drives that I do not want to change as I, J, K, & L. I have bought a new Cruzer and sent the old one to my buddy but the new one seems to follow the same rules as the old one and is only recognized as if I had never changed anything. I am assuming that there is something on my computer that was installed by this device but I cannot find it in the area where programs are uninstalled... Why that is I have no idea. When I do a search on uninstalling I only get how to uninstall the software from the device and not the computer. I have moved the drive letters to other places such as setting up the Cruzer as Y & Z but nothing so far has worked. I have considered uninstalling the software on the Cruzer and using it as a "dumb thumbdrive" but I am reluctant to do this. Before I stoop to this low level can you help me solve this?

 

Thank you,

Gary