Reply
SanDisk Fanatic
Posts: 214
Registered: ‎06-20-2008

Spotty recognizition of SD card in MTP mode.

I just added a replacement SD card to my Fuze+ and the player see's it, and it enumerates fine in MSC mode, but it does not always get detected in MTP mode.

 

As a result, many times, my Fuze is seen as only an 8GB player instead of the 37 GB player it is with the card installed.

 

My card is therefore unaccessable to Rhapsody and  I can't make the playlists I normally make.

 

The wierd thing is sometimes it works fine.  I don't know the secret.  I've tried the different USB ports on my laptop and also I have tried to plug it in when it is off and when it is on and it's still a shot in the dark,

 

It's pretty wierd.  I'm running Windows 7 64 bit.  Does anyone know if there are updates to the MTP drivers.   I'm pretty sure it's with Windows since it is seen fine on other machines in the house with different operating systems.

 

SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: Spotty recognizition of SD card in MTP mode.

Opus, that's a really weird one.  WiMP12 is part of Windows7, and should have the latest and greatest MTP requisites.  If you disconnect the fuze, does the card report under settings > info?

 

See is it's a Rhapsody client issue by looking in the sources pane when the Fuze+ is plugged in.  Leave the client (Rhapsody 4) open, and click on the taskbar of Win7, look under the Device Stage button (Fuze+ icon) for the microSD card.

 

Next, click on the Libraries button on the taskbar, and you'll get the new Windows Explorer box.  See if the Fuze and microSD both list under Computer as removable devices.  It will be interesting to see if it's a Windows problem or if it may be the client.

 

Bob  Smiley Wink

SanDisk Fanatic
Posts: 214
Registered: ‎06-20-2008

Re: Spotty recognizition of SD card in MTP mode.

Here's where it gets weirder:

 

If I "connect" the device prior to booting the laptop, it appears both with the internal and external memory enumerated.  However, if I connect it to the laptop "after"  the OS has already booted, it only enumerates the internal memory.  This ONLY happens in MTP mode, btw. 

 

Real weirdness. 

 

Oh well, I'll just have to connect my sansa prior to starting my laptop.

 

 

SanDisk Guru
Posts: 5,822
Registered: ‎12-26-2007

Re: Spotty recognizition of SD card in MTP mode.

Try connecting the Fuze+ in MTP mode, in fact, manually select MTP on the device prior to connecting.

 

Go to the Device manager in Windows 7, and try uninstalling the device.  By doing this, you accomplish a refreshing of the registry entry for the Fuze+.  Unplug, wait 30 seconds for good measure (allow the Fuze+ to refresh if any transfers were made), then plug in again.

 

Windows will make a new registry entry for the Fuze+.  I just had a thought- there may have been a "ghost entry" there, Windows refers to the registry as a cheat sheet telling it what to do with the device.  If there's a problem with the adaptation, Windows will ignore the device, making it look like the device isn't there at all.  This could be the case with your mounted card.

 

You should be greeted with the mask "New device found.  MTP device."

 

Let me know if this solves the bizarre enumeration issue for you.

 

Bob  Smiley Tongue

SanDisk Fanatic
Posts: 214
Registered: ‎06-20-2008

Re: Spotty recognizition of SD card in MTP mode.

it worked once.  Then I unplugged and replugged in again and it went back to not recognizing the card.  At least I know now how to get it to re-enumerate correctly without rebooting the box.

 

Newbie
Posts: 2
Registered: ‎06-30-2011

Re: Spotty recognizition of SD card in MTP mode.

I have the same problem as you.

 

I switched the USB setting to MSC and now windows can see it.

 

I still havent figured out how to have the Fuze+ use the SD card yet though.. It either says a format error and do not find the card if I try to format it from the Fuze+..

 

Highlighted
SanDisk Professor
Posts: 473
Registered: ‎07-28-2010

Re: Spotty recognizition of SD card in MTP mode.


@SadPanda wrote:

 

I still havent figured out how to have the Fuze+ use the SD card yet though.. It either says a format error and do not find the card if I try to format it from the Fuze+..

 


Wait for the next firmware release. It should fix that problem

Newbie
Posts: 1
Registered: ‎05-22-2011

Re: Spotty recognizition of SD card in MTP mode.

I've had the same issue- the only way i found to get it to work is to uninstall the device everytime you unplug it from your laptop and let win7 redetected it everytime.