Reply
Newbie
Posts: 3
Registered: ‎08-24-2019

Sansa M240 Playlist=No Files Windows 10 Problem???

Sansa M240 & had several Playlists that worked fine. Upgraded to Windows 10 then added a few mp3 songs to a playlist but now says, “No Files”. It still plays mp3s without using a Playlist.

Transferred mp3s to hard drive, created 2 new playlists with 2 & 50 mp3s, both worked on the PC but same "No Files" on the M240.

Reformatted M240 and reinstalled most recent driver (2.1.0A). Transferred music & this time created Playlist on the M240. Same “No Files” result but still plays mp3s without using a Playlist.

Tried 6 different Playlist creation programs all with the same results.

My 2 theories are Windows 10:

(1) tags the Playlist file in some way that the Sansa M240 can't recognize or

(2) recognizes the M240 as a different type of device than previous Windows versions.

 

Any help is appreciated,

DDBob.

SanDisk Guru
Posts: 16,304
Registered: ‎04-17-2008

Re: Sansa M240 Playlist=No Files Windows 10 Problem???


@ddbob wrote:

Sansa M240 & had several Playlists that worked fine. Upgraded to Windows 10 then added a few mp3 songs to a playlist but now says, “No Files”. It still plays mp3s without using a Playlist.

Transferred mp3s to hard drive, created 2 new playlists with 2 & 50 mp3s, both worked on the PC but same "No Files" on the M240.

 


 

This might be your problem. You have to create playlists from the files located on the player, otherwise the path to them will be wrong & the player will not be able to find them.

Newbie
Posts: 3
Registered: ‎08-24-2019

Re: Sansa M240 Playlist=No Files Windows 10 Problem???

Thank you for replying.

Tried that & got the same results.  One program allows path examination & it was correct to the M240.

So strange.

DDBob.

 

Highlighted
Newbie
Posts: 3
Registered: ‎08-24-2019

Re: Sansa M240 Playlist=No Files Windows 10 Problem???

Done a lot more work, same results.

 

Windows 10 File Explorer has a path of:

This PC\Sansa m240 \TCNAND0\Music

 

Media Monkey's path is missing everything except:

\Music

 

I'm thinking Window's 10 is supposed to remove “This PC” from the Playlist path and leave “\Sansa m240 \TCNAND0\Music” but instead removes everything except the last folder “\Music”. Resulting in an invalid path so the m240 says “No Files”.

 

Thoughts?

 

DDBob.