Posts: 1
Registered: ‎10-17-2017

Re: Sansa Clip Zip Firmware 01.01.21


I want to connect my clipzip to a macbook. I followed the instructions to update the firmware but after transferring the extracted files to the root clipzip file and disconnecting the device, nothing happens. What did I do wrong? Thank you.

Posts: 4
Registered: ‎04-06-2018

Re: Sansa Clip Zip Firmware 01.01.21

What to do when your Sansa zip clip has no folders and is completely empty?


That's what happened to me...

Does anyone know a solution...


This is all the info I have:



All the info in one place:
My Black Sansa Clip Zip 4 GB doesn't turn on but is seen on my Windows 10 Computer. I connect it to my Computer on the backside with USB 3.0.
I tested if the battery works. I think it does charge because I held a voltmeter on the battery and it read 3,75 volt.
Another problem the Sandisk had no folders and no files on it so I can't do a firmware update...
This is what happened the whole story:

A few weeks ago I found my old SanDisk sansa clipzip mp3 player and I thought: Hey, I haven't seen you in a while... I tried to use it and then i remembered I stopped using it a long time ago because it froze and I tried some things...

I tried to connect it to my computer and tried to reset it and I tried more things like doing things on my pc... But it didn't work...

I remembered when I got my first smartphone I grabbed this micro sd card (at that time it didn't work already) and used it for my phone. I don't konw if that adds to the way to fix it.
My computer can see it but the sandisk doesn't do anything...

I hope maybe one of you can maybe help me! I would really apreciate that!