Reply
Newbie
Posts: 6
Registered: ‎07-30-2007

Multiple M200 Devices

    I have 3 different M200 devices and have recently run into a problem.  The devices are: 1 pink 1gb M240 v.4.1.08a
1 blue 512mb M230 v.4.1.08a, and  1 blue 512mb M230 v.1.3.0
The pink one runs fine...no problems there.  However, the two M230's have just started not connecting to my PC if in the "Auto Detect" mode.  They just "bong" and I get the yellow exclamation marks in the device manager.
I can connect them in "MSC" mode however...go figure.
Here is the catch...I have a second PC and they all work fine on it....however all of my music is on the PC they don't connect to.
Does anyone know what might be causing this???
I did recently get an ipod and installed it on the PC that doesn't recognize the M230's.
Has anyone else run into any issues with ipods and sansa's?
Darin
SanDisk Senior User
Posts: 104
Registered: ‎07-20-2007

Re: Multiple M200 Devices

Typically its an issue with DRM on that system if the device loads in MSC mode and works in MTP mode on another PC.
 
Try running the MSN Troubleshooter to see if it can find the issue with your DRM.
Newbie
Posts: 6
Registered: ‎07-30-2007

Re: Multiple M200 Devices

    What exactly is DRM?
I ran the troubleshooter.  It had me uninstall and reinstall.  The reinstallation failed..."problem installing MTP device...specified device does not exist as an installed service"
Thanks for your help.
Darin
SanDisk Senior User
Posts: 104
Registered: ‎07-20-2007

Re: Multiple M200 Devices

DRM=Digital Rights Management
 
What OS are you using and what version of media player do you have?
Newbie
Posts: 6
Registered: ‎07-30-2007

Re: Multiple M200 Devices

    After uninstalling and reinstalling, now the pink M240 does not connect either in the "Auto Detect".   Just the triple "bong"!!!
I have Windows XP Home with sp2 and WMP 11.
Highlighted
SanDisk Senior User
Posts: 104
Registered: ‎07-20-2007

Re: Multiple M200 Devices

Does the device show in Device Manager?
Newbie
Posts: 6
Registered: ‎07-30-2007

Re: Multiple M200 Devices

Yes it does...it shows the correct label for each device, with a yellow exclamation.

SanDisk Senior User
Posts: 104
Registered: ‎07-20-2007

Re: Multiple M200 Devices

Right click on the device in device manager and give me the error code it has.
Newbie
Posts: 6
Registered: ‎07-30-2007

Re: Multiple M200 Devices

    "Reinstall the drivers for this device. (Code 18)"
After going throught the reinstall wizard and trying to download a driver from Windows I get:  "There was a problem installing this hardware: MTP Device......An error occurred during the installation of the device.  The specified service does not exist as an installed service."
Is it possible to download a driver and install it that way?


SanDisk Senior User
Posts: 104
Registered: ‎07-20-2007

Re: Multiple M200 Devices

[ Edited ]
It sounds to me like you system has a issue with Windows. The drivers for the device in MTP mode are provided by microsoft and are included in Windows Media Player 10 and higher. If the device works in MTP mode on another PC the problem is with windows on your PC.


Message Edited by Narse on 07-30-2007 03:32 PM