Reply
Highlighted
Newbie
Posts: 2
Registered: ‎05-03-2013
Accepted Solution

M240 can not see my files on Windows 7

I have a M240 with a lot of music on it. I do not remember when I put it on. Years ago I guess. I connected it to my windows 7 laptop and can see three folders (audible, config, record) and a .dnc file. However, my music is not there. What the heck is going on? Any help would be greatly appreciated.

Highlighted
Newbie
Posts: 2
Registered: ‎05-03-2013

Re: M240 can not see my files on Windows 7

Fixed it. Apparently you have to set the USB mode to Auto detect. It must be in MTP mode instead of MSC mode to view and upload files to the player from a windows 7 system. Hopefully that helps someone.

Highlighted
SanDisk Guru
Posts: 16,317
Registered: ‎04-17-2008

Re: M240 can not see my files on Windows 7

[ Edited ]

Not really. You should never use the Auto Defect setting. This defaults to MTP mode, but can also connect in MSC mode if conditions for MTP are not just right (different computer, phase of the moon, etc.).

 

If the files were originally loaded in MTP, then that would be why your computer cannot see them if connected in MSC mode. The reverse is also true, files loaded in MSC mode cannot be seen while connected in MTP.

 

It sounds like your files were loaded in MTP mode. You should manually set the USB Mode to MTP. Again, it is not advised to use the Auto setting. Smiley Wink

Highlighted
SanDisk User
Posts: 59
Registered: ‎03-31-2013

Re: M240 can not see my files on Windows 7

Thanks. But in out of the box, is it set at default, USB or MSC mode?
Highlighted
SanDisk Guru
Posts: 16,317
Registered: ‎04-17-2008

Re: M240 can not see my files on Windows 7


@dwaynnyt wrote:
Thanks. But in out of the box, is it set at default, USB or MSC mode?

Smiley Smiley

Highlighted
Newbie
Posts: 1
Registered: ‎06-24-2013

Re: M240 can not see my files on Windows 7

I am using Windows 7.  I've had my Sansa for several years now and suddenly my computer does not recognize it.  My USB setting is not set to auto detect and my only option to use is MSC, I don't see MTP.  I use my device to listen to audio books and my public library uses Overdrive software.  I have always downloaded WMA format and everything works fine.  Now suddenly, when I try to transfer from Overdrive to my player, I get a message saying the device is not recognized for WMA, so I am unable to transfer any audio books to Sansa using my laptop.  HOWEVER, it would work using windows XP on a different computer.  I would like to use my Windows 7 laptop.  Any ideas how to get it working again??  Thanks!!! Lady