Reply
Newbie
Posts: 4
Registered: ‎02-03-2013

Fuze+ audio sync issues

I like to take the Fuze+ with me when traveling, so I put DVD movies converted to mp4 onto the SD card to watch while on the plane/train. However, almost without exception, the audio and video gets out of sync. Yes, I follow the video requirement guidelines, and tried lower variations to no avail. I've also tried splitting the movies into 45 minute segments, but they get out of sync as well. Is there a magic solution to this? I have tried SMC, Handbrake, Any Video Converter, video4fuze, and several others. The best one so far is Handbrake. I would say at this point, 80% have the sync problem.

SanDisk Fanatic
Posts: 398
Registered: ‎07-09-2009

Re: Fuze+ audio sync issues

Gee, if I had a penny for everytime that's happened to me. This type of problem often requires per-bases geekery. You're probably more likely to get help from videohelp.com, since... well I think the name says it all.

 

First I would try opening the file with Media Info, and post your results. Also, try playing the video on your computer, and see if this happens on the computer, also.

 

That's all I've got for now. 

Tired of the Sansa Media Converter? Try Video4Fuze! It can create smaller videos than SMC, and is WAY more reliable!!!!

Newbie
Posts: 4
Registered: ‎02-03-2013

Re: Fuze+ audio sync issues

Update: I followed the video requirements posted in this forum, and it seems to have fixed the majority of the synching issues.

Basically, that the video cannot be larger than 320w x 240h, no anamorphic, mpeg4 ffmpeg codec, 29.97 constant framerate, avg bitrate of 1000 kbps, aac (faac) stereo with 44.1 samplerate and 128 bitrate. I also try to cut videos into pieces that are no longer than 1 hour each (most are around 42-46 minutes).

 

However, I still have some files that just are not read in the Sansa. I have had a lot of trouble with micro SD cards lately, and that happened after the latest firmware update. I did not have trouble before that. I cannot use the Sansa encoder because it fails every time and errors that it cannot write to the device. So, the synching is fixed by using Handbrake and the above settings.

 

Thanks, halonachos117 for the tip. I will keep trying!

SanDisk Fanatic
Posts: 398
Registered: ‎07-09-2009

Re: Fuze+ audio sync issues

[ Edited ]

The Sansa Media Converter is most certainly crap. Thank goodness that the Fuze+ can read videos from a large number of encoders/converters, unlike the thumbwheel Fuze.

 

However, I've had slightly different results than you. Anamorphic video plays fine for me (the decoder shouldn't know the difference). I've also had full-length movies, some as long as three hours, play just fine. You can use pretty much any constant framerate, as long as you don't exceed 30. Any bitrate will due for both audio and video, as long as the video bitrate doesn't exceed Level 2.0 specs* (pretty much anything that isn't ridiculous for such a small screen).

 

*If you're not using an AVC/X.264 encoder, Level 2.0 means nothing to you.

Tired of the Sansa Media Converter? Try Video4Fuze! It can create smaller videos than SMC, and is WAY more reliable!!!!

Highlighted
Moderator
Posts: 497
Registered: ‎01-19-2009

Re: Fuze+ audio sync issues

It takes a few minutes, but the Fuze+ can accept video from Windows Media Player directly as well. I've had some video files perform better if they are transferred this way.

 

microsansa