Reply
SanDisk User
Posts: 22
Registered: ‎10-03-2009

Audiobooks, tagging and other issues...

I am a longtime user of the Clip+. Loved the Clip+ and used the heck out of it. Eventually the clip on the back broke off and I decided it was time to get a new one.   So I now have a new Clip Zip, and am having some issues with it.

 

The main thing I use my mp3 player for is listening to audio books. One of the reasons why I went with the Clip+ was because it supported file/folder browsing (i.e. you could listen to stuff that wsnt' id3 tagged). On my Clip Zip I can still do this, but only with music. I do not seem to be able to access audiobooks through file browsing. 

 

Is there any way to do this? Am I missing something? Removing file/folder browswing for audiobooks seems to be to be a big step backwards. I really hope there is some kind of a workaround for this! (I already tried just putting the audio books in a folder under "music"--but the problem with this is that you don't get bookmarking under music. So if you know of a way to enable bookmarks in music, let me know!)

 

But since I haven't been able to figure this out, I've been trying to make things work using the id3 tags. Some of my stuff works, but some it seems wildly off.

 

I have one book where it seems the files are id3 tagged correctly but go from 1/234 to 234/234. On the Clip Zip, the files are all out of order. I read something ont the Clip+ forum that there is a bug that makes the files go out of order if you use the 1/234 to 234/234 type format, and the second number (after the slash) is greater than 100. It would seemt that Sandisk did not fix this bug in the Clip Zip (but let me know if I'm missing something). The suggested workaround was jus tto remove the slash and the second number. Does anyone know of a way to do this as a "batch" process without having to individually change every file by hand? (If it matters, I have a Mac, but can use Windows solutions too, because there is a Windows computer I can access.)

 

Something else, when listening to an audio book on the Clip Zip, a quick  press of the right or left buttons does NOT take me to the next audio file, although a long press (holding the button down) does fast-forward and fast-reverse in the same file. Is this normal? And is there any work around? (While listening to music, a  quick press does take forwards or backwards to the next song, just as expected.)

 

All help and suggestions appreciated. Thanks in advance!

 

BTW, I hate to say this, but part of me is even considering just returning the Clip Zip and getting another Clip+. (I checked and see they are still available.)   Is this something I should give more serious conideration to this?  I do like the color screen on the Clip Zip, but I can do without it, and other then that I haven't yet noticed any big advantages that the Clip Zip has over the Clip+. And the inability to file/folder browse audiobooks seems a pretty big dis-advantage...

 

 

 

 

 

SanDisk User
Posts: 22
Registered: ‎10-03-2009

Re: Audiobooks, tagging and other issues...

[ Edited ]

Another oddity:

 

Using my Mac, I loaded audiobooks and music into both the internal memory and onto a microSD chip that is in the player.

 

Now I just plugged the player into my Windows 7 machine at work, and everything (both folders and files) that I loaded onto the player's INTERNAL memory using my Mac is "invisible" in Windows Explorer. (Not only that, but now I can see 4 preinstalled folders of sample music that were "invisible on my Mac!)  But Windows Explorer does correctly show that the internal memory is full, even if it's not showing the files filling it.

 

In contrast, when I use the Windows 7 machine to look at the EXTERNAL MEMORY (the microSD ship) I CAN see the folders I installed with my Mac, but NOT the actual audio folders.

 

Why is it that the stuff I installed on the internal memory using my Mac is not visible in Windows? (And seemingly vice versa.) 

 

This was never a problem with my Clip+. I could use my Mac or Windows machine interchangeabley to place, view or remove files on my Clip+.

 

Is there anything I can do to "fix" this? Or are there any workarounds?

 


Edit: I should add that not only could I use the Clip+ interchangebly on my Mac or Windows machine, but I've always been able to do this with thumb drives as well.  But for some reason the Clip Zip isn't playing well...

 

SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: Audiobooks, tagging and other issues...

Your Zip is obviously set to the infamous and dreaded Auto Defect USB setting. In this mode, it will connect in either MTP or MSC mode depending on the computer used.

 

Your Mac requires MSC. Therefore, it connected in that mode when you added all your music files. Now, when you plugged it into your Win 7 machine at work, the player detected that Windows Media Player was present and defaultly connected in MTP mode.

 

The reason this is relevant is that files added in one mode cannot be seen while connected in the other. Hence, you cannot see the files on your PC that were added when connected to your Mac.

 

Easy to fix though . . . just go to Settings > System Settings > USB Mode on your Zip and manually select MSC mode. Now all you files added on your Mac should be visible to you on your work computer.

 

Apparently your previous Clip+ was already set to MSC mode explaining why you never noticed this before.

 

In short . . . never use the Auto Defect setting. Smiley Wink

SanDisk User
Posts: 22
Registered: ‎10-03-2009

Re: Audiobooks, tagging and other issues...

Thanks for the tip about Sandisk's "Auto Defect" setting. Now that you mention it, I remember having a lot of trouble with the Clip+ with the MSC vs. USB modes, and I didn't even have a Mac back then.... I'd completely forgotten about this. Blocked it out again.

 

Even with it set to MSC, the sample music tracks are still "invisible" on my Mac...so I'll just delete using my work computer...

 

There's no way to use file/folder browsing mode in audiobooks?

 

I just spent 5-6 hours learning how tagging works and then tagging or fixing the tagging on the books I'm loading onto the player. But I wish I could just use file/folder browsing, because I have a ton more of books and they all are really easy to play in file/folder mode without having to worry about proper tagging.

SanDisk Guru
Posts: 16,315
Registered: ‎04-17-2008

Re: Audiobooks, tagging and other issues...


@stridr wrote:

 

Even with it set to MSC, the sample music tracks are still "invisible" on my Mac...so I'll just delete using my work computer...

 



That's because the "sample" tracks are added in MTP mode at the factory. Remember, MTP mode won't work with your Mac. You'll have to switch to MTP mode on your work PC in order to see and delete them.

 


@stridr wrote:

 

But I wish I could just use file/folder browsing, because I have a ton more of books and they all are really easy to play in file/folder mode without having to worry about proper tagging.

 



You can, if you put the books in the Music folder instead of the Audiobooks folder. But this can get confusing if you also have music tracks installed there.