Reply
Newbie
Posts: 9
Registered: ‎02-17-2011

Album Artwork Problems

Hello. I know the album art subject has been addressed before, but I still can use some fresh advice.
I bought a new Fuze+ and dragged over 500 songs from the Music folder in to the Fuze+ music folder.(firmware updated)
None were full albums-mostly selected cuts from albums. In the Windows Media library every song has artwork-the cover or the"unknown album" logo I found online. I had "updated album info" from the menu. On the Fuze now there are many, many songs without artwork(generic designs show) and I don't know why.
Even when I play these songs from my hard drive WMP shows the artwork.
Why didn't the artwork transfer to the Fuze with the songs? I should mention that I have a Zune and that these songs were backed up on an external HD before a Windows reinstall.
I copied these songs to my computer HD but I did NOT copy the folder jpg's or desktop ini. because the artwork on the Zune was messed up.
Thanks in advance for any and all help.

SanDisk Fanatic
Posts: 214
Registered: ‎06-20-2008

Re: Album Artwork Problems

The Fuze seems to read only "embedded" artwork that is actually embedded into the track.

 

Windows Media player usually associates various music with "album art" pictures that it uses to display album art when played via Media player.  This is why the art is just fine in Media Player.  However, the Fuze will only read art that is actually embedded in the track.

 

The easiest way to do this is a program file call MP3Tag.  This program allows you to take an existing album art file and embed it into the track itself.

 

 

SanDisk User
Posts: 59
Registered: ‎11-07-2010

Re: Album Artwork Problems

[ Edited ]

The Fuze+ will also display album art if the album art is saved as the file folder.jpg in the same folder as the song tracks.  However, the Fuze+ does a poor job of reading this album art unless it is copied at the same time the tracks are loaded onto the device.  Therefore, if the songs are already on your Fuze+, you will need to remove them from your Fuze+ (simply delete them if the songs are still on your computer, otherwise cut and paste them off your Fuze+), then allow your Fuze+ to rebuild its database (this will happen when you disconnect it from your computer), then put the album art saved as folder.jpg in the individual album folders, then copy it all back onto your Fuze+.  Now when the database rebuilds it will properly read the album art.

 

I believe even if you try to use something like MP3tag to tag the files, you must do this with the files OFF your device (remove from device first and let database rebuild if necessary), then copy them back onto the device, and rebuild database again.

 

Incidentally, does anyone know a way to force the database to completely rebuild in order to avoid the steps I outlined above (which I've test and works, but is annoying.)

Newbie
Posts: 9
Registered: ‎02-17-2011

Re: Album Artwork Problems

Thank you for your replies. I don't however have my songs in folders. They are all single songs. Of course WMP assigns most of them to albums but in Explorer they remain single songs.

SanDisk User
Posts: 59
Registered: ‎11-07-2010

Re: Album Artwork Problems

In that case you will need to embed the artwork in the track.  The other user recommends MP3tag to do this.  I've used MediaMonkey to do this and have had success as well.

SanDisk Fanatic
Posts: 214
Registered: ‎06-20-2008

Re: Album Artwork Problems

You can embed album art using MP3 Tag on the device directly if you are using MSC mode.  I've done it many times.  It however is pretty dog slow.

 

I make a ritual whenever I rip new music.

 

Tag as necessary -> adjust gain using Mp3Gain -> Embed Album art -> then load to device and save backup to external drive.

Highlighted
Newbie
Posts: 9
Registered: ‎02-17-2011

Re: Album Artwork Problems

Hi again and thanks for the input. Let me ask another related question.. In the library of WMP as I mentioned all of the artwork shows. Evidently some are imbedded, some are not. If I right-click on an album cover "find album art" and reconfirm the existing cover will that imbed the artwork?

Also I consider myself to be very computer-literate, but I don't understand the term "tag" as it refers to imbedding artwork. I've read the manual for MP3Tag but don't quite follow. Could someone breeze thru the steps for me for imbedding artwork? Are the other programs easier to use?

Newbie
Posts: 3
Registered: ‎04-03-2011

Re: Album Artwork Problems

[ Edited ]

Okay, so I embedded all the album art in the fuze at 300 x 300 resolution, rebuilt the database and used MSC mode to easily change the content with MP3TAG. This was an attempt to fix some problematic albums that didn't want to show or had white edges, and nothing changed but a couple albums. There is still 13 albums that won't display correctly and is a pain to look at. Does any one have and insight on how to fix this problem?