Reply
Highlighted
Newbie
Posts: 1
Registered: ‎12-17-2019

32GB SanDisk Cruzer Blade - stopped working

Hi all,

 

Yesterday my pen drive of 32GB stopped working (SanDisk Cruzer Blade).

 

The reason may be, i had a word document file opened from the pen drive, and made some changes and saved it. After sometime i removed the pen drive with the word doc file still opened, also even without selecting the Safe Remove Hardware. May me this is the issue?

 

I had few important files, but now even after following this: "https://kb.sandisk.com/app/answers/detail/a_id/205/~/sandisk-device-not-detected-by-windows-pc "... still the pen drive is not being dedected by the Desktop PC, tried all the ports on the Laptop too, not dedecting, tried with a 2nd laptop, still not dedecting.

 

Also i checked the Device Manager, on an another solution here in forum, checked the USB section, there was one 'unknown device', when the pen drive connected, i removed it, but when i scan the USB section, it is unable to install a 'AMD Log Utility Driver' (screenshot attached), not sure if this has anything to do with the USB port....Any solution for this please? Smiley Sad

USB driver may be.jpg
Highlighted
SanDisk Guru
Posts: 2,880
Registered: ‎07-23-2010

Re: 32GB SanDisk Cruzer Blade - stopped working

Not Safe Removed, particularly with a file open, most definitely screwed up the drive's file allocation table.  Running a CHKDSK command on the drive is the only thing that I know of that corrects this.  Do NOT try writing anything to the drive until you get it fixed else you may permanently loose your files.

Ed
Important files = Backed up files