Y! Music Jukebox won't recognize Connect

My heat problem from yesterday seems to not have replicated himself but I have a new problem: the Yahoo Music Jukebox app won’t recognize my Connect anymore.  The “Portable Devices” tab, in fact, disappears completely from the Jukebox software when I connect(!).  My PC seems to recognize the Connect since the autoplay option always pops up after connecting.  I’ve tried reinstalling Yahoo Jukebox, connecting from different USB ports but nothing has worked yet.  Any suggestions?

EDIT: OK, I ended up having to do a factory reset to the Connect :neutral_face: but it’s now being recognized by Yahoo Jukebox.  Unfortunately, because I had to reinstall Jukebox a couple of times, I have to let the software reacquire all of the licenses before I can sync the Connect again.  I hope these sorts of interface issues get ironed out in future firmware updates…

Message Edited by rpn777x on 08-26-2007 05:11 PM

Message Edited by rpn777x on 08-26-2007 07:10 PM

I’m assuming you just got the Sansa Connect.

Since your Connect is right out of the box, it should have gotten a firmware update downloaded while you were connected via WiFi (listening to Internet Radio). It could take up to 20 minutes to get the update. Did you see any messages stating the Connect was getting a firmware update when you first used Internet Radio? If you did, make sure you reboot completely by holding the power button about 8-10 seconds and then powering up again to load the new firmware.

Note:  There were reports that the firmware shipped on the Connect had MTP error recovery problem. Full reboot of the Connect would clear the error. If you hold power button 1-2 seconds the Connect goes into sleep mode which will not clear the error. Firmware ZAP an higher includes improved MTP error handling which should resolve your problem.

*** Update ***

New firmware released Nov 6th

The released version number is:

Message Edited by Greig on 11-07-2007 11:02 AM

Yeah, I did both of those things when I first got the Connect.  I experienced the same problem again just this morning and fixed it with the same solution as I reported in my edit.  I’m wondering at this point if it’s some kind of interface issue with Vista since I’m running that OS’s Home Premium edition (and Vista gets to be the scapegoat for every problem now :wink: ).  Anyway, I guess it’s not a big deal for now; I just end up losing my favorite stations and having to resync my Connect each time.  If anyone else can share any other insights and/or advice, it would be appreciated.

Next time this happens, try resetting your Sansa Connect.  Note, this reset procedure doesn’t erase the contents on your device:

Just hold the power button for about 20 seconds.  When you let go, you should see the Sansa Connect go through its booting procedure.  Once that is complete try connecting to your PC again.

Let us know if this helps you.